aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-16 20:02:38 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 07:10:13 -0700
commitc3ecb5aa5ebfa3b475ea70276e6f7ae4463c826b (patch)
tree9e3051feba541694a769ff9f85b9957ddce5a924 /configure.ac
parent191e520999c172a5316c3b54c2b32ab7ff32be36 (diff)
downloadmpd-c3ecb5aa5ebfa3b475ea70276e6f7ae4463c826b.tar.gz
mpd-c3ecb5aa5ebfa3b475ea70276e6f7ae4463c826b.tar.xz
mpd-c3ecb5aa5ebfa3b475ea70276e6f7ae4463c826b.zip
configure.ac: Move ALSA to Audio Output Plugins (nonstreaming), add subheader.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 13 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index b79e09ef8..20ae3ed19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -858,6 +858,19 @@ dnl ---------------------------------------------------------------------------
dnl Audio Output Plugins (Nonstreaming)
dnl ---------------------------------------------------------------------------
+dnl ----------------------------------- ALSA ----------------------------------
+MPD_AUTO_PKG(alsa, ALSA, [alsa >= 0.9.0],
+ [ALSA output plugin], [libasound not found])
+
+if test x$enable_alsa = xyes; then
+ AC_DEFINE(HAVE_ALSA, 1, [Define to enable ALSA support])
+fi
+
+AM_CONDITIONAL(HAVE_ALSA, test x$enable_alsa = xyes)
+
+
+
+
MPD_AUTO_PKG(ao, AO, [ao],
[libao output plugin], [libao not found])
if test x$enable_ao = xyes; then
@@ -974,17 +987,6 @@ fi
AM_CONDITIONAL(HAVE_MVP, test x$enable_mvp = xyes)
-MPD_AUTO_PKG(alsa, ALSA, [alsa >= 0.9.0],
- [ALSA output plugin], [libasound not found])
-
-if test x$enable_alsa = xyes; then
- AC_DEFINE(HAVE_ALSA, 1, [Define to enable ALSA support])
-fi
-
-AM_CONDITIONAL(HAVE_ALSA, test x$enable_alsa = xyes)
-
-
-
if test x$enable_mpc = xyes; then
if test "x$mpcdec_libraries" != "x" ; then
MPCDEC_LIBS="-L$mpcdec_libraries"