aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-09 22:22:06 +0100
committerMax Kellermann <max@duempel.org>2009-02-09 22:22:54 +0100
commitbee688e99aa45f8e5e5612873471a3ff5e918578 (patch)
treedf2b06e994404c47b0120b4e7c5abfc896af1409 /configure.ac
parentd9ce8d8342a2399c8e45cecb932b09d20b7254e1 (diff)
downloadmpd-bee688e99aa45f8e5e5612873471a3ff5e918578.tar.gz
mpd-bee688e99aa45f8e5e5612873471a3ff5e918578.tar.xz
mpd-bee688e99aa45f8e5e5612873471a3ff5e918578.zip
configure.ac: define HAVE_FFMPEG after all checks
Don't define HAVE_FFMPEG if the ffmpeg libraries were found via pkg-config, but ffmpeg support was disabled because avcodec_decode_audio2() is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 36801c5da..cb2eb92dc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -975,8 +975,7 @@ fi
AM_CONDITIONAL(HAVE_MODPLUG, test x$enable_modplug = xyes)
if test x$enable_ffmpeg = xyes; then
- PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],
- AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+ PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],,
enable_ffmpeg=no)
fi
@@ -999,6 +998,10 @@ if test x$enable_ffmpeg = xyes; then
CPPCFLAGS=$old_CPPFLAGS
fi
+if test x$enable_ffmpeg = xyes; then
+ AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+fi
+
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)