aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-11-02 17:20:07 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-11-02 17:20:07 +0000
commitbaf8efff5b1f77764ed1cc5ce73fcd66536aa150 (patch)
treed62340e87c02657790653b3b3dc4f00f0561c4be /configure.ac
parentc1bbb35f587a19c95aade233bf063fe060a85372 (diff)
downloadmpd-baf8efff5b1f77764ed1cc5ce73fcd66536aa150.tar.gz
mpd-baf8efff5b1f77764ed1cc5ce73fcd66536aa150.tar.xz
mpd-baf8efff5b1f77764ed1cc5ce73fcd66536aa150.zip
disable shout support if vorbis not found
git-svn-id: https://svn.musicpd.org/mpd/trunk@2477 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 1a91d80bd..492ea84d1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -102,6 +102,12 @@ AP_maGiC_VALUE
fi
if test x$enable_ao = xyes; then
+ if test x$enable_ogg = xno; then
+ AC_MSG_WARN("disabling shout streaming support since vorbis was not found")
+ fi
+fi
+
+if test x$enable_ao = xyes; then
XIPH_PATH_AO(MPD_LIBS="$MPD_LIBS $AO_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AO_CFLAGS",AC_MSG_ERROR(Must have libao installed!!!))
AC_DEFINE(HAVE_AUDIO, 1, [Define to play audio])
fi