aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 22:45:00 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 22:45:00 +0200
commitb914d3f6eb88e9efdf5f977e41f71bf76ef2b0d8 (patch)
treedaf1334890529efb5b08fcb4796b5c6bb96d93f2 /configure.ac
parent780ce492493738d0992a617d605efcd048975c86 (diff)
downloadmpd-b914d3f6eb88e9efdf5f977e41f71bf76ef2b0d8.tar.gz
mpd-b914d3f6eb88e9efdf5f977e41f71bf76ef2b0d8.tar.xz
mpd-b914d3f6eb88e9efdf5f977e41f71bf76ef2b0d8.zip
Makefile.am: use TREMOR_CFLAGS and TREMOR_LIBS
Don't append those two CFLAGS/LIBS in configure.ac.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 6 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index de026d403..2f09f5988 100644
--- a/configure.ac
+++ b/configure.ac
@@ -782,11 +782,10 @@ if test x$use_tremor = xyes; then
LIBS="$LIBS $TREMOR_LIBS"
AC_CHECK_LIB(vorbisidec,ov_read,enable_oggvorbis=yes,enable_oggvorbis=no;
AC_MSG_WARN([vorbisidec lib needed for ogg support with tremor -- disabling ogg support]))
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
if test x$enable_oggvorbis = xyes; then
- AC_DEFINE(HAVE_OGGVORBIS, 1, [Define for Ogg Vorbis support]),
- else
- CFLAGS="$ac_save_CFLAGS"
- LIBS="$ac_save_LIBS"
+ AC_DEFINE(HAVE_OGGVORBIS, 1, [Define for Ogg Vorbis support])
fi
elif test x$enable_oggvorbis = xyes; then
PKG_CHECK_MODULES(OGGVORBIS, [ogg vorbis vorbisfile],
@@ -805,6 +804,9 @@ if test x$use_tremor = xyes; then
fi
fi
+AC_SUBST(TREMOR_CFLAGS)
+AC_SUBST(TREMOR_LIBS)
+
if test x$enable_flac = xyes; then
PKG_CHECK_MODULES(FLAC, [flac >= 1.1],
AC_DEFINE(HAVE_FLAC, 1, [Define for FLAC support]),