aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2006-07-17 08:22:50 +0000
committerEric Wong <normalperson@yhbt.net>2006-07-17 08:22:50 +0000
commitb545a7e57de94715ec86060ee875abc0a9784567 (patch)
treed4810650f3e419bf12b5fd74b762114667cef591 /configure.ac
parentc919ffd1bfe7a37d11ed7b0abdcaa6469e10b0d0 (diff)
downloadmpd-b545a7e57de94715ec86060ee875abc0a9784567.tar.gz
mpd-b545a7e57de94715ec86060ee875abc0a9784567.tar.xz
mpd-b545a7e57de94715ec86060ee875abc0a9784567.zip
Fix some autotools related problems
Huge thanks to gnarlie for helping me find and diagnose several problems stemming from autogen.sh on FreeBSD 6.1 We require autoconf 2.58 for autogen.sh, but it seems like that's always been the case, we just never caught it before :/ "bash ./configure" just about sums up what I want to do right now... git-svn-id: https://svn.musicpd.org/mpd/trunk@4384 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 11 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 5d9f3bdf8..000805232 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,7 +1,7 @@
dnl AC_INIT(src/main.c)
dnl AM_INIT_AUTOMAKE(mpd, 0.12.0)
-AC_PREREQ(2.52)
+AC_PREREQ(2.58)
AC_INIT(mpd, 0.12.0, warren.dukes@gmail.com)
AM_INIT_AUTOMAKE($PACKAGE_NAME, $PACKAGE_VERSION)
@@ -234,7 +234,11 @@ if test x$enable_id3 = xyes; then
CFLAGS=$oldcflags
LIBS=$oldlibs
CPPFLAGS=$oldcppflags
- AC_DEFINE(HAVE_ID3TAG,1,[Define to use id3tag])
+ if $use_libid3tag = xyes; then
+ AC_DEFINE(HAVE_ID3TAG,1,[Define to use id3tag])
+ else
+ enable_id3=no
+ fi
fi
MAD_SUBDIR=""
@@ -274,7 +278,11 @@ if test x$enable_mp3 = xyes; then
CFLAGS=$oldcflags
LIBS=$oldlibs
CPPFLAGS=$oldcppflags
- AC_DEFINE(HAVE_MAD,1,[Define to use libmad])
+ if test x$use_libmad = xyes; then
+ AC_DEFINE(HAVE_MAD,1,[Define to use libmad])
+ else
+ enable_mp3=no
+ fi
fi
if test x$enable_mpc = xyes; then