aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-10-21 10:30:42 +0200
committerMax Kellermann <max@duempel.org>2009-10-21 10:30:42 +0200
commitb479a264b66a5cb74fc8424d7d47035fdfad8799 (patch)
tree7c8b68a64dd642e4a3ce041080f93f7bbca70660 /configure.ac
parentac32f36e4e1489664e7c202319978b6a9a15ed40 (diff)
downloadmpd-b479a264b66a5cb74fc8424d7d47035fdfad8799.tar.gz
mpd-b479a264b66a5cb74fc8424d7d47035fdfad8799.tar.xz
mpd-b479a264b66a5cb74fc8424d7d47035fdfad8799.zip
pulse: code rewrite using the asynchronous libpulse API
This is a complete rewrite of the PulseAudio output plugin. It uses the asynchronous API, which gives us more control over everything. Additionally, it connects to the PulseAudio server on startup, and keeps this connection up while MPD runs. During pause, instead of closing the stream, it enables "cork".
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 885115971..150e81aa0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -726,7 +726,7 @@ AC_ARG_ENABLE(pulse,
[enable support for the PulseAudio sound server]),,
enable_pulse=auto)
-MPD_AUTO_PKG(pulse, PULSE, [libpulse-simple],
+MPD_AUTO_PKG(pulse, PULSE, [libpulse],
[PulseAudio output plugin], [libpulse not found])
if test x$enable_pulse = xyes; then
AC_DEFINE([HAVE_PULSE], 1,