aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-08-26 08:27:02 +0200
committerMax Kellermann <max@duempel.org>2008-08-26 08:27:02 +0200
commita383f4511734b978020b1f8b4360ef9ad438e929 (patch)
tree36eed149dc77683414b81e91b463a5a4376d000e /configure.ac
parentd05c8fd422266f5769ba8bde1ee23a20a73578a7 (diff)
downloadmpd-a383f4511734b978020b1f8b4360ef9ad438e929.tar.gz
mpd-a383f4511734b978020b1f8b4360ef9ad438e929.tar.xz
mpd-a383f4511734b978020b1f8b4360ef9ad438e929.zip
enable -Wpointer-arith, -Wstrict-prototypes
Also enable -Wunused-parameter - this forces us to add the gcc "unused" attribute to a lot of parameters (mostly library callback functions), but it's worth it during code refactorizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d48a237bc..6ea93089f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -26,11 +26,12 @@ if test x$GCC = xyes
then
MPD_CHECK_FLAG([-Wall])
MPD_CHECK_FLAG([-Wextra])
- MPD_CHECK_FLAG([-Wno-unused-parameter])
MPD_CHECK_FLAG([-Wno-deprecated-declarations])
MPD_CHECK_FLAG([-Wmissing-prototypes])
MPD_CHECK_FLAG([-Wdeclaration-after-statement])
MPD_CHECK_FLAG([-Wshadow])
+ MPD_CHECK_FLAG([-Wpointer-arith])
+ MPD_CHECK_FLAG([-Wstrict-prototypes])
fi
if test -z "$prefix" || test "x$prefix" = xNONE; then