aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-01 15:36:24 +0200
committerMax Kellermann <max@duempel.org>2009-04-01 15:36:24 +0200
commita3823c7657e486b371577e669c3171becb1678b7 (patch)
tree7e04d76f368c29c4cdbb3b12017d16664b3a335a /configure.ac
parent85cecbddde93aa4bcb7821473ea95ccad150ce4c (diff)
parent4bfbdfe5c522011a695c804cfccf190eb4500e9a (diff)
downloadmpd-a3823c7657e486b371577e669c3171becb1678b7.tar.gz
mpd-a3823c7657e486b371577e669c3171becb1678b7.tar.xz
mpd-a3823c7657e486b371577e669c3171becb1678b7.zip
Merge branch 'master' of git://git.musicpd.org/jrk/mpd
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e4e0c2ea9..b77344825 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,6 +169,20 @@ dnl ##
dnl misc libraries
dnl ##
+AC_ARG_ENABLE(cue,
+ AS_HELP_STRING([--enable-cue],
+ [enable support for libcue support]),,
+ enable_cue=auto)
+
+MPD_AUTO_PKG(cue, CUE, [libcue],
+ [libcue parsing library], [libcue not found])
+if test x$enable_cue = xyes; then
+ AC_DEFINE([HAVE_CUE], 1,
+ [Define to enable libcue support])
+fi
+
+AM_CONDITIONAL(HAVE_CUE, test x$enable_cue = xyes)
+
dnl ##
dnl Avahi / Zeroconf
dnl ##
@@ -1385,6 +1399,12 @@ else
echo " Zeroconf support ..............disabled"
fi
+if test x$enable_cue = xyes; then
+ echo " libcue support ................enabled"
+else
+ echo " libcue support ................disabled"
+fi
+
echo ""
echo "##########################################"
echo ""