aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2005-01-16 16:03:14 +0000
committerWarren Dukes <warren.dukes@gmail.com>2005-01-16 16:03:14 +0000
commit9999a20c12f37fa853f4df8eab279d3d4c58f97d (patch)
treed0efa2632b7c63b8d377b8050f6b6233de717756 /configure.ac
parent9a18f61d4891841b601bc46d2a8e03a61b6f2184 (diff)
downloadmpd-9999a20c12f37fa853f4df8eab279d3d4c58f97d.tar.gz
mpd-9999a20c12f37fa853f4df8eab279d3d4c58f97d.tar.xz
mpd-9999a20c12f37fa853f4df8eab279d3d4c58f97d.zip
this should fix compile bugs #350 and #351
git-svn-id: https://svn.musicpd.org/mpd/trunk@2884 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 13 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index c15a115ba..0ad23a90e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -31,11 +31,11 @@ if test x$CC = xgcc; then
fi
MPD_LIBS=""
-AC_ARG_ENABLE(audio,[ --disable-audio disable support for playing],,enable_ao=yes)
+AC_ARG_ENABLE(ao,[ --disable-ao disable support for libao],,enable_ao=yes)
AC_ARG_ENABLE(shout,[ --disable-shout disable support for streaming through shout],,enable_shout=yes)
AC_ARG_ENABLE(iconv,[ --disable-iconv disable iconv support],,enable_iconv=yes)
AC_ARG_ENABLE(ipv6,[ --disable-ipv6 disable IPv6 support],,enable_ipv6=yes)
-AC_ARG_ENABLE(alsa,[ --disable-oss disable OSS support],,enable_oss=yes)
+AC_ARG_ENABLE(oss,[ --disable-oss disable OSS support],,enable_oss=yes)
AC_ARG_ENABLE(alsa,[ --disable-alsa disable ALSA Mixer support],,enable_alsa=yes)
AC_ARG_ENABLE(ogg,[ --disable-ogg disable ogg support],,enable_ogg=yes)
AC_ARG_ENABLE(flac,[ --disable-flac disable flac support],,enable_flac=yes)
@@ -101,15 +101,13 @@ AP_maGiC_VALUE
)
fi
-if test x$enable_ao = xyes; then
- if test x$enable_ogg = xno; then
- AC_MSG_WARN("disabling shout streaming support since vorbis was not found")
- fi
+if test x$enable_ogg = xno; then
+ AC_MSG_WARN("disabling shout streaming support since vorbis was not found")
fi
if test x$enable_ao = xyes; then
XIPH_PATH_AO(MPD_LIBS="$MPD_LIBS $AO_LIBS" MPD_CFLAGS="$MPD_CFLAGS $AO_CFLAGS",AC_MSG_ERROR(Must have libao installed!!!))
- AC_DEFINE(HAVE_AUDIO, 1, [Define to play audio])
+ AC_DEFINE(HAVE_AO, 1, [Define to play with ao])
fi
if test x$enable_shout = xyes; then
@@ -535,9 +533,15 @@ fi
echo ""
echo "Audio Format Support:"
if test x$enable_ao = xyes; then
- echo "Playing audio .................enabled"
+ echo "Playing audio via libao .......enabled"
+else
+ echo "Playing audio via libao .......disabled"
+fi
+
+if test x$enable_oss = xyes; then
+ echo "Playing audio via OSS .........enabled"
else
- echo "Playing audio .................disabled"
+ echo "Playing audio via OSS .........disabled"
fi
if test x$enable_shout = xyes; then