aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-27 18:04:34 +0100
committerMax Kellermann <max@duempel.org>2009-03-27 18:04:34 +0100
commit8fa44d53ab1c1edb0a78da32b69f4f71b91817db (patch)
tree9ffcceac1591c835951c3af73c37b765dad42bef /configure.ac
parent94479ca40fad5e483dca6d363542792df3d5f589 (diff)
downloadmpd-8fa44d53ab1c1edb0a78da32b69f4f71b91817db.tar.gz
mpd-8fa44d53ab1c1edb0a78da32b69f4f71b91817db.tar.xz
mpd-8fa44d53ab1c1edb0a78da32b69f4f71b91817db.zip
configure.ac: require GLib 2.6
We're using GLib macros which were introduced in GLib 2.6, like G_GNUC_MALLOC. Let's just drop support for GLib versions older than 2.6 instead of adding more complicated compatibility hacks.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cd14c42f6..94e01bc0d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -108,8 +108,8 @@ dnl
dnl mandatory libraries
dnl
-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.4 gthread-2.0],,
- [AC_MSG_ERROR([glib-2.4 is required])])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.6 gthread-2.0],,
+ [AC_MSG_ERROR([glib-2.6 is required])])
dnl