aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-09-25 18:32:00 +0200
committerMax Kellermann <max@duempel.org>2009-09-25 18:32:00 +0200
commit8f261af5c1cfd6f922df009e17756fa3bef71458 (patch)
treedd5dd4bd6d41d1536e31f32e502e473e40520663 /configure.ac
parent3e8bdb93844eb21f4a34d4f586e51f869933ebb8 (diff)
downloadmpd-8f261af5c1cfd6f922df009e17756fa3bef71458.tar.gz
mpd-8f261af5c1cfd6f922df009e17756fa3bef71458.tar.xz
mpd-8f261af5c1cfd6f922df009e17756fa3bef71458.zip
automatically update the database with Linux inotify
This patch implements a light-weight inotify library, and watches all directories below the music directory. It updates all directories where files changed after a delay of 5 seconds.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d0d215762..6522060e6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -118,6 +118,9 @@ AC_CHECK_LIB(m,exp,MPD_LIBS="$MPD_LIBS -lm",)
AC_CHECK_HEADERS(locale.h)
AC_CHECK_HEADERS(valgrind/memcheck.h)
+AC_CHECK_FUNCS(inotify_init)
+AM_CONDITIONAL(HAVE_INOTIFY, test x$ac_cv_func_inotify_init = xyes)
+
dnl
dnl mandatory libraries