aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2006-07-26 20:51:50 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2006-07-26 20:51:50 +0000
commit8dcc3d31ac92e0eb632f17bd6ccf5c34fa08106d (patch)
treea584b0472482591f0ddbfeb558f2fd91c4e8e0ba /configure.ac
parent907fe56029ead527a439127d39e54c9283b5d65e (diff)
downloadmpd-8dcc3d31ac92e0eb632f17bd6ccf5c34fa08106d.tar.gz
mpd-8dcc3d31ac92e0eb632f17bd6ccf5c34fa08106d.tar.xz
mpd-8dcc3d31ac92e0eb632f17bd6ccf5c34fa08106d.zip
Remove the fifo plugin. It's currently useless for the average user, and making it more presentable isn't something I'm willing to do before 0.12. It will likely be added back after 0.12, along with some very experimental stuff to make it more usable.
git-svn-id: https://svn.musicpd.org/mpd/trunk@4472 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 3d08665ae..0349faa3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -69,7 +69,6 @@ AC_ARG_ENABLE(sun,[ --disable-sun disable sun support (default: enabl
AC_ARG_ENABLE(oss,[ --disable-oss disable OSS support (default: enable)],[enable_oss=$enableval],[enable_oss=yes])
AC_ARG_ENABLE(alsa,[ --disable-alsa disable ALSA support (default: enable)],[enable_alsa=$enableval],[enable_alsa=yes])
AC_ARG_ENABLE(pulse,[ --disable-pulse disable support for the PulseAudio sound server (default: enable)],[enable_pulse=$enableval],[enable_pulse=yes])
-AC_ARG_ENABLE(fifo,[ --enable-fifo enable support for writing audio to a FIFO (default: disable)],[enable_fifo=$enableval],[enable_fifo=no])
AC_ARG_ENABLE(mvp,[ --enable-mvp enable support for Hauppauge Media MVP (default: disable)],[enable_mvp=$enableval],[enable_mvp=no])
AC_ARG_ENABLE(oggvorbis,[ --disable-oggvorbis disable Ogg Vorbis support (default: enable)],[enable_oggvorbis=$enableval],enable_oggvorbis=yes)
AC_ARG_ENABLE(oggflac,[ --disable-oggflac disable OggFLAC support (default: enable)],[enable_oggflac=$enableval],enable_oggflac=yes)
@@ -179,12 +178,6 @@ if test x$enable_pulse = xyes; then
[enable_pulse=no;AC_MSG_WARN([PulseAudio not found -- disabling])])
fi
-if test x$enable_fifo = xyes; then
- AC_CHECK_FUNC([mkfifo],
- [enable_fifo=yes;AC_DEFINE([HAVE_FIFO], 1, [Define to enable support for writing audio to a FIFO])],
- [enable_fifo=no;AC_MSG_WARN([mkfifo not found -- disabling support for writing audio to a FIFO])])
-fi
-
if test x$enable_mvp = xyes; then
AC_DEFINE(HAVE_MVP,1,[Define to enable Hauppauge Media MVP support])
fi
@@ -679,12 +672,6 @@ else
echo " PulseAudio support ............disabled"
fi
-if test x$enable_fifo = xyes; then
- echo " FIFO support ..................enabled"
-else
- echo " FIFO support ..................disabled"
-fi
-
if test x$enable_mvp = xyes; then
echo " Media MVP support .............enabled"
else
@@ -706,7 +693,6 @@ if test x$enable_ao = xno &&
test x$enable_alsa = xno &&
test x$enable_osx = xno &&
test x$enable_pulse = xno &&
- test x$enable_fifo = xno &&
test x$enable_mvp = xno; then
AC_MSG_ERROR("No Audio Output types configured!")
fi