aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorSerge Ziryukin <ftrvxmtrx@gmail.com>2009-08-31 10:26:22 +0300
committerMax Kellermann <max@duempel.org>2009-09-06 17:34:56 +0200
commit8b6a5d19d01ddf0657a64634ccd66b6fde66b735 (patch)
tree7dc7aee402dc42411d45efe3e8310ab2ffc9311b /configure.ac
parent129920e8f418d029350ce3c463948eba55d6775c (diff)
downloadmpd-8b6a5d19d01ddf0657a64634ccd66b6fde66b735.tar.gz
mpd-8b6a5d19d01ddf0657a64634ccd66b6fde66b735.tar.xz
mpd-8b6a5d19d01ddf0657a64634ccd66b6fde66b735.zip
openal output plugin
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index e730c6977..b74fbf9b0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -711,6 +711,11 @@ AC_ARG_ENABLE(oss,
[disable OSS support (default: enable)]),,
enable_oss=yes)
+AC_ARG_ENABLE(openal,
+ AS_HELP_STRING([--enable-openal],
+ [enable OpenAL support (default: disable)]),,
+ enable_openal=no)
+
AC_ARG_ENABLE(pulse,
AS_HELP_STRING([--enable-pulse],
[enable support for the PulseAudio sound server]),,
@@ -779,6 +784,19 @@ fi
AM_CONDITIONAL(HAVE_OSS, test x$enable_oss = xyes)
+if test x$enable_openal = xyes; then
+ PKG_CHECK_MODULES([OPENAL], [openal],
+ AC_DEFINE(HAVE_OPENAL, 1, [Define for OpenAL support]),
+ enable_openal=no)
+fi
+
+if test x$enable_openal = xyes; then
+ MPD_CFLAGS="$MPD_CFLAGS $OPENAL_CFLAGS"
+ MPD_LIBS="$MPD_LIBS $OPENAL_LIBS"
+fi
+
+AM_CONDITIONAL(HAVE_OPENAL, test x$enable_openal = xyes)
+
if test x$enable_fifo = xyes; then
AC_CHECK_FUNC([mkfifo],
[enable_fifo=yes;AC_DEFINE([HAVE_FIFO], 1,
@@ -1297,6 +1315,12 @@ else
echo " OSS support ...................disabled"
fi
+if test x$enable_openal = xyes; then
+ echo " OpenAL support ................enabled"
+else
+ echo " OpenAL support ................disabled"
+fi
+
if test x$enable_osx = xyes; then
echo " OS X support ..................enabled"
else
@@ -1338,6 +1362,7 @@ echo ""
if
test x$enable_ao = xno &&
test x$enable_oss = xno &&
+ test x$enable_openal = xno &&
test x$enable_shout = xno &&
test x$enable_recorder_output = xno &&
test x$enable_httpd_output = xno &&