aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-28 21:48:07 +0100
committerMax Kellermann <max@duempel.org>2009-03-28 21:48:07 +0100
commit87e0b1adc48557af5a469a38d65a4e3c2d6a7637 (patch)
treee16509788bdf2acd66bf843cdaf47ee40e736335 /configure.ac
parent33aeac4fcbc1f7a53304d1677b5ac01bb4ce3766 (diff)
downloadmpd-87e0b1adc48557af5a469a38d65a4e3c2d6a7637.tar.gz
mpd-87e0b1adc48557af5a469a38d65a4e3c2d6a7637.tar.xz
mpd-87e0b1adc48557af5a469a38d65a4e3c2d6a7637.zip
configure.ac: added M4 function MPD_AUTO_PKG() for ALSA
MPD_AUTO_PKG() runs pkg-config and then forwards control to MPD_AUTO_RESULT(). This is a commonly used short cut.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 2 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 3d6ec62af..d34855955 100644
--- a/configure.ac
+++ b/configure.ac
@@ -682,12 +682,8 @@ fi
AM_CONDITIONAL(HAVE_MVP, test x$enable_mvp = xyes)
-if test x$enable_alsa != xno; then
- PKG_CHECK_MODULES(ALSA, [alsa >= 0.9.0],
- found_alsa=yes, found_alsa=no)
-fi
-
-MPD_AUTO_RESULT([alsa], [ALSA output plugin], [libasound not found])
+MPD_AUTO_PKG(alsa, ALSA, [alsa >= 0.9.0],
+ [ALSA output plugin], [libasound not found])
if test x$enable_alsa = xyes; then
AC_DEFINE(HAVE_ALSA, 1, [Define to enable ALSA support])