aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-26 11:06:11 +0200
committerMax Kellermann <max@duempel.org>2014-09-26 11:06:11 +0200
commit8547611479f8169497d257da5e40dcd885398865 (patch)
tree3a2cd4e5559ced80479c4e7024493bf12705f4fb /configure.ac
parent45310d0cf6731bad36956510e5c54faab691a877 (diff)
parentfe45f282044c3500894f65b94a514ebe799da6a1 (diff)
downloadmpd-8547611479f8169497d257da5e40dcd885398865.tar.gz
mpd-8547611479f8169497d257da5e40dcd885398865.tar.xz
mpd-8547611479f8169497d257da5e40dcd885398865.zip
Merge tag 'v0.18.16'
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac56
1 files changed, 13 insertions, 43 deletions
diff --git a/configure.ac b/configure.ac
index e3d4730f4..c7fa6d1c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -369,6 +369,11 @@ AC_ARG_ENABLE(documentation,
[build documentation (default: disable)]),,
[enable_documentation=no])
+AC_ARG_ENABLE(dsd,
+ AS_HELP_STRING([--enable-dsd],
+ [enable DSD decoder (default: enable)]),,
+ [enable_dsd=yes])
+
AC_ARG_ENABLE(ffmpeg,
AS_HELP_STRING([--enable-ffmpeg],
[enable FFMPEG support]),,
@@ -1133,6 +1138,14 @@ if test x$enable_audiofile = xyes; then
AC_DEFINE(HAVE_AUDIOFILE, 1, [Define for audiofile support])
fi
+dnl ----------------------------------- DSD -----------------------------------
+
+if test x$enable_dsd = xyes; then
+ AC_DEFINE(ENABLE_DSD, 1, [Define for the DSD decoder])
+fi
+
+AM_CONDITIONAL(ENABLE_DSD, test x$enable_dsd = xyes)
+
dnl ----------------------------------- FAAD ----------------------------------
AM_PATH_FAAD()
@@ -1386,28 +1399,6 @@ AM_CONDITIONAL(ENABLE_WILDMIDI, test x$enable_wildmidi = xyes)
dnl ------------------------ Post Decoder Plugins Tests -----------------------
-if
- test x$enable_aac = xno &&
- test x$enable_audiofile = xno &&
- test x$enable_ffmpeg = xno &&
- test x$enable_flac = xno &&
- test x$enable_fluidsynth = xno &&
- test x$enable_mad = xno &&
- test x$enable_mikmod = xno; then
- test x$enable_modplug = xno &&
- test x$enable_mp4v2 = xno &&
- test x$enable_mpc = xno &&
- test x$enable_mpg123 = xno &&
- test x$enable_opus = xno &&
- test x$enable_sidplay = xno &&
- test x$enable_tremor = xno &&
- test x$enable_vorbis = xno &&
- test x$enable_wavpack = xno &&
- test x$enable_wildmidi = xno &&
-
- AC_MSG_ERROR([No input plugins supported!])
-fi
-
AM_CONDITIONAL(HAVE_XIPH,
test x$enable_vorbis = xyes || test x$enable_tremor = xyes || test x$enable_flac = xyes || test x$enable_opus = xyes)
@@ -1713,27 +1704,6 @@ fi
AM_CONDITIONAL(ENABLE_WINMM_OUTPUT, test x$enable_winmm_output = xyes)
-dnl --------------------- Post Audio Output Plugins Tests ---------------------
-if
- test x$enable_alsa = xno &&
- test x$enable_roar = xno &&
- test x$enable_ao = xno &&
- test x$enable_fifo = xno &&
- test x$enable_httpd_output = xno &&
- test x$enable_jack = xno &&
- test x$enable_openal = xno &&
- test x$enable_oss = xno &&
- test x$enable_osx = xno &&
- test x$enable_pipe_output = xno &&
- test x$enable_pulse = xno &&
- test x$enable_recorder_output = xno &&
- test x$enable_shout = xno &&
- test x$enable_solaris_output = xno &&
- test x$enable_winmm_output = xno; then
-
- AC_MSG_ERROR([No Audio Output types configured!])
-fi
-
dnl ---------------------------------------------------------------------------
dnl Documentation
dnl ---------------------------------------------------------------------------