aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKalle Wallin <kaw@linux.se>2004-04-19 22:12:53 +0000
committerKalle Wallin <kaw@linux.se>2004-04-19 22:12:53 +0000
commit7e3af33b2a6623f026fe80eb8c5026817f9d444a (patch)
tree261501be61897d6872cd26657a275b33bed49426 /configure.ac
parent230b0fe73ac3a07293d495e895207b43cdfb3369 (diff)
downloadmpd-7e3af33b2a6623f026fe80eb8c5026817f9d444a.tar.gz
mpd-7e3af33b2a6623f026fe80eb8c5026817f9d444a.tar.xz
mpd-7e3af33b2a6623f026fe80eb8c5026817f9d444a.zip
Added keydef screen
git-svn-id: https://svn.musicpd.org/ncmpc/trunk@834 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 20 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 989f9bb02..bc3345108 100644
--- a/configure.ac
+++ b/configure.ac
@@ -17,6 +17,8 @@ dnl =======================================================
set -- $CFLAGS
CFLAGS="-Wall $CFLAGS"
+keydef_screen=yes
+
dnl
dnl Check for types
dnl
@@ -27,9 +29,6 @@ dnl )
AC_SOCKLEN_T
-
-
-
dnl
dnl Check for headers
dnl
@@ -71,23 +70,35 @@ AC_CHECK_LIB(popt,
dnl Debugging
AC_ARG_ENABLE(debug,
- [ --enable-debug Enable debugging [default=no]],
+ AS_HELP_STRING([--enable-debug],[Enable debugging]),
,
enable_debug=no)
if test "$enable_debug" = yes; then
- CFLAGS="$CFLAGS -g -DDEBUG"
+ CFLAGS="$CFLAGS -g -DDEBUG"
fi
+dnl Key editor
+AC_ARG_ENABLE(key-editor,
+ AS_HELP_STRING([--enable-key-editor],[Enable key editor]),
+ keydef_screen=no,
+ keydef_screen=yes)
+if test "$keydef_screen" = yes; then
+ CFLAGS="$CFLAGS -DENABLE_KEYDEF_SCREEN"
+fi
+dnl AC_DEFINE(ENABLE_KEYDEF_SCREEN, 1, [Enable builtin key editor]),
+
+
dnl Default host
AC_ARG_WITH(default-host,
- [ --with-default-host=HOST Default host (localhost)],
+ AS_HELP_STRING([--with-default-host=ARG],
+ [Default MPD host (localhost)]),
DEFAULT_HOST="$withval",
DEFAULT_HOST="localhost")
dnl Default port
AC_ARG_WITH(default-port,
- [ --with-default-port=PORT Default port (2100)],
+ AS_HELP_STRING([--with-default-port=ARG],[Default port (2100)]),
DEFAULT_PORT="$withval",
DEFAULT_PORT="2100")
@@ -109,8 +120,9 @@ echo "
Configuration:
prefix: ${prefix}
sysconfdir: ${sysconfdir}
- Enable debugging: ${enable_debug}
Default MPD host: ${DEFAULT_HOST}
Default MPD port: ${DEFAULT_PORT}
+ Enable debugging: ${enable_debug}
+ Key edit screen: ${keydef_screen}
"
echo