aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2007-02-02 03:51:07 +0000
committerAvuton Olrich <avuton@gmail.com>2007-02-02 03:51:07 +0000
commit79ef8ba2480eef73d5863945e270c539e7b4aac6 (patch)
treeb94bfd1ebf394208ee0c5f4bfc9ad2008b00771f /configure.ac
parent96c5976cccf61e0310879e69f51ba235e6b1729d (diff)
downloadmpd-79ef8ba2480eef73d5863945e270c539e7b4aac6.tar.gz
mpd-79ef8ba2480eef73d5863945e270c539e7b4aac6.tar.xz
mpd-79ef8ba2480eef73d5863945e270c539e7b4aac6.zip
Add libsamplerate support, old resampling is still an option, but this sounds much better for those who need it and don't want to use pulseaudio. Reviewed by shank/avuton.
git-svn-id: https://svn.musicpd.org/mpd/trunk@5316 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac21
1 files changed, 20 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8b41bbad0..95386d296 100644
--- a/configure.ac
+++ b/configure.ac
@@ -11,6 +11,7 @@ AC_SUBST(MP4FF_LIB)
AC_SUBST(MP4FF_SUBDIR)
AC_PROG_CC
+AM_PROG_CC_C_O
AC_PROG_INSTALL
AC_PROG_LIBTOOL
AC_PROG_MAKE_SET
@@ -79,6 +80,7 @@ AC_ARG_ENABLE(audiofile,[ --disable-audiofile disable audiofile support, di
AC_ARG_ENABLE(mod,[ --enable-mod enable MOD support (default: disable],[enable_mod=$enableval],[enable_mod=yes])
AC_ARG_ENABLE(mpc,[ --disable-mpc disable musepack (MPC) support (default: enable)],[enable_mpc=$enableval],[enable_mpc=yes])
AC_ARG_ENABLE(id3,[ --disable-id3 disable id3 support (default: enable)],[enable_id3=$enableval],[enable_id3=yes])
+AC_ARG_ENABLE(lsr,[ --disable-lsr disable libsamplerate support (default: enable)],[enable_lsr=$enableval],[enable_lsr=yes])
AC_ARG_WITH(tremor,[[ --with-tremor[=PFX] Use Tremor(vorbisidec) integer Ogg-Vorbis decoder (with optional prefix)]], use_tremor=yes; test x$withval != xyes && tremor_prefix="$withval",)
AC_ARG_WITH(tremor-libraries,[ --with-tremor-libraries=DIR Directory where Tremor library is installed (optional)], tremor_libraries="$withval", tremor_libraries="")
@@ -101,6 +103,10 @@ AC_ARG_WITH(faad-libraries,[ --with-faad-libraries=DIR Directory where faad2
AC_ARG_WITH(faad-includes,[ --with-faad-includes=DIR Directory where faad2 header files are installed (optional)], faad_includes="$withval", faad_includes="")
AC_ARG_WITH(zeroconf,[[ --with-zeroconf=[auto|avahi|bonjour|no] Enable zeroconf backend (default=auto)]], with_zeroconf="$withval", with_zeroconf="auto")
+AC_ARG_WITH(lsr,[ --with-src=PFX Prefix where libsamplerate is installed], src_prefix="$withval", src_prefix="")
+AC_ARG_WITH(lsr-libraries,[ --with-lsr-libraries=DIR Directory where libsamplerate library is installed (optional)], lsr_libraries="$withval", lsr_libraries="")
+AC_ARG_WITH(lsr-includes,[ --with-lsr-includes=DIR Directory where libsamplerate header files are installed (optional)], lsr_includes="$withval", lsr_includes="")
+
AC_C_BIGENDIAN
AC_CHECK_SIZEOF(short)
@@ -186,6 +192,12 @@ if test x$enable_pulse = xyes; then
[enable_pulse=no;AC_MSG_WARN([PulseAudio not found -- disabling])])
fi
+if test x$enable_lsr = xyes; then
+ PKG_CHECK_MODULES([SAMPLERATE], [samplerate >= 0.0.15],
+ [enable_lsr=yes;AC_DEFINE([HAVE_LIBSAMPLERATE], 1, [Define to enable libsamplerate])] MPD_LIBS="$MPD_LIBS $SAMPLERATE_LIBS" MPD_CFLAGS="$MPD_CFLAGS $SAMPLERATE_CFLAGS",
+ [enable_lsr=no;AC_MSG_WARN([libsamplerate not found -- disabling])])
+fi
+
if test x$enable_mvp = xyes; then
AC_DEFINE(HAVE_MVP,1,[Define to enable Hauppauge Media MVP support])
fi
@@ -777,8 +789,15 @@ if
fi
echo ""
-
echo " Other features:"
+
+if test x$enable_lsr = xyes; then
+ echo " libsamplerate support .........enabled"
+else
+ echo " libsamplerate support .........disabled"
+fi
+
+
if test x$with_zeroconf != xno; then
echo " Zeroconf support ..............$with_zeroconf"
else