aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorEric Wong <normalperson@yhbt.net>2007-01-14 04:25:19 +0000
committerEric Wong <normalperson@yhbt.net>2007-01-14 04:25:19 +0000
commit6f341e9a3b047f8eea0e7ff3b52488bbaa6e23ff (patch)
treea3ac0ea3e903f60842a7bd1c85922dcb78252440 /configure.ac
parentb443363aa6081749883a92f9955a95c4301df00a (diff)
downloadmpd-6f341e9a3b047f8eea0e7ff3b52488bbaa6e23ff.tar.gz
mpd-6f341e9a3b047f8eea0e7ff3b52488bbaa6e23ff.tar.xz
mpd-6f341e9a3b047f8eea0e7ff3b52488bbaa6e23ff.zip
configure.ac: get rid of scary message about OggFLAC with FLAC 1.1.3
We don't need to check for libOggFLAC with FLAC 1.1.3 because FLAC 1.1.3 can be recompiled to enable/disable OggFLAC support without recompiling mpd. git-svn-id: https://svn.musicpd.org/mpd/trunk@5255 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac16
1 files changed, 13 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 2296ec903..fcdcc7946 100644
--- a/configure.ac
+++ b/configure.ac
@@ -549,6 +549,10 @@ if test x$enable_flac = xyes; then
if test x$enable_flac = xno; then
MPD_CFLAGS="$oldmpdcflags"
MPD_LIBS="$oldmpdlibs"
+ else
+ AC_CHECK_DECL(FLAC_API_SUPPORTS_OGG_FLAC,
+ [enable_oggflac=flac], [],
+ [#include <FLAC/export.h>])
fi
CFLAGS="$oldcflags"
LIBS="$oldlibs"
@@ -726,11 +730,17 @@ else
echo " FLAC support ..................disabled"
fi
-if test x$enable_oggflac = xyes; then
+case $enable_oggflac in
+yes)
echo " OggFLAC support ...............enabled"
-else
+ ;;
+flac)
+ echo " OggFLAC support ...............enabled(FLAC 1.1.3)"
+ ;;
+*)
echo " OggFLAC support ...............disabled"
-fi
+ ;;
+esac
if test x$enable_audiofile = xyes; then
echo " Wave file support .............enabled"