aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorVictor A. Safronov <vitek@vitek.tomsk.ru>2009-05-26 16:16:53 +0200
committerMax Kellermann <max@duempel.org>2009-05-26 16:16:53 +0200
commit6e3bd4f620022f5a6a1a464170fba1bdfa242e7e (patch)
treebf3c76b2d2b44e681a80a8503de3beeb67bf3d29 /configure.ac
parenta2de0f0fc59bb92bbb15a40c088e4cb5524fe395 (diff)
downloadmpd-6e3bd4f620022f5a6a1a464170fba1bdfa242e7e.tar.gz
mpd-6e3bd4f620022f5a6a1a464170fba1bdfa242e7e.tar.xz
mpd-6e3bd4f620022f5a6a1a464170fba1bdfa242e7e.zip
Incorrect identifying of --with-tremor option in configure.ac
[mk: moved check out of the AC_ARG_WITH block]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 7e009d850..b9f7e13a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -475,9 +475,15 @@ dnl Ogg Tremor
dnl ###
AC_ARG_WITH(tremor,
AS_HELP_STRING([--with-tremor=PFX],
- [use Tremor (vorbisidec) integer Ogg Vorbis decoder (with optional prefix)]),
- use_tremor=yes; test x$withval != xyes && tremor_prefix="$withval",
- )
+ [use Tremor (vorbisidec) integer Ogg Vorbis decoder (with optional prefix)]),,
+ with_tremor=no)
+
+if test x$with_tremor = xyes || test x$with_tremor = xno; then
+ use_tremor="$with_tremor"
+else
+ tremor_prefix="$with_tremor"
+ use_tremor=yes
+fi
AC_ARG_WITH(tremor-libraries,
AS_HELP_STRING([--with-tremor-libraries=DIR],