aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-04-15 22:23:50 +0200
committerMax Kellermann <max@duempel.org>2009-04-15 22:23:50 +0200
commit60f5150d2b585af3a939f12d0105e5ecb23d6a12 (patch)
treefde084e9ba642f19566eb6bc37b882bdabcefab6 /configure.ac
parentd23a23db10f3b22dbd44c897f349cd2f556173de (diff)
downloadmpd-60f5150d2b585af3a939f12d0105e5ecb23d6a12.tar.gz
mpd-60f5150d2b585af3a939f12d0105e5ecb23d6a12.tar.xz
mpd-60f5150d2b585af3a939f12d0105e5ecb23d6a12.zip
configure.ac: moved the sidplay check to its argument
Checks for features should be right next to its argument definition.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 11 insertions, 11 deletions
diff --git a/configure.ac b/configure.ac
index da73fd4c1..46e6197ab 100644
--- a/configure.ac
+++ b/configure.ac
@@ -476,6 +476,17 @@ AC_ARG_ENABLE(sidplay,
[enable C64 SID support via libsidplay2 (default: disable)]),,
enable_sidplay=no)
+if test x$enable_sidplay = xyes; then
+ # we have no test yet.. we're not using pkg-config here
+ # because libsidplay2's .pc file requires libtool
+ AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder")
+ AC_SUBST(SIDPLAY_CFLAGS,)
+
+ AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
+fi
+
+AM_CONDITIONAL(ENABLE_SIDPLAY, test x$enable_sidplay = xyes)
+
AC_ARG_ENABLE(fluidsynth,
AS_HELP_STRING([--enable-fluidsynth],
[enable MIDI support via fluidsynth (default: disable)]),,
@@ -891,17 +902,6 @@ fi
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
-if test x$enable_sidplay = xyes; then
- # we have no test yet.. we're not using pkg-config here
- # because libsidplay2's .pc file requires libtool
- AC_SUBST(SIDPLAY_LIBS,"-lsidplay2 -lresid-builder")
- AC_SUBST(SIDPLAY_CFLAGS,)
-
- AC_DEFINE(ENABLE_SIDPLAY, 1, [Define for libsidplay2 support])
-fi
-
-AM_CONDITIONAL(ENABLE_SIDPLAY, test x$enable_sidplay = xyes)
-
if test x$enable_fluidsynth = xyes; then
PKG_CHECK_MODULES(FLUIDSYNTH, [fluidsynth],
AC_DEFINE(ENABLE_FLUIDSYNTH, 1, [Define for fluidsynth support]),