aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-03-21 13:47:45 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-03-21 13:47:45 +0000
commit590323e3411fb0db4e9f75f132a0b74ebe3eb3e3 (patch)
treeb90c7c3828c0eddc9fe4fe29448ca288bcb6fab8 /configure.ac
parent89d096fbef7871692746e584bd148af554e867ad (diff)
downloadmpd-590323e3411fb0db4e9f75f132a0b74ebe3eb3e3.tar.gz
mpd-590323e3411fb0db4e9f75f132a0b74ebe3eb3e3.tar.xz
mpd-590323e3411fb0db4e9f75f132a0b74ebe3eb3e3.zip
more faad autoconf checks
git-svn-id: https://svn.musicpd.org/mpd/trunk@342 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 68950ab28..9c91c527a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -255,9 +255,13 @@ if test x$enable_aac = xyes; then
LIBS="$LIBS $MPD_LIBS $FAAD_LIBS"
AC_CHECK_HEADER(faad.h,,enable_aac=no)
if test x$enable_aac = xyes; then
- AC_CHECK_LIB(faad, faacDecDecode,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ AC_CHECK_DECL(faacDecInit2,,enable_aac=no,[#include <faad.h>])
fi
if test x$enable_aac = xyes; then
+ AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ fi
+ if test x$enable_aac = xyes; then
+ AC_CHECK_MEMBERS([faacDecConfiguration.downMatrix,faacDecConfiguration.dontUpSampleImplicitSBR],,,[#include <faad.h>])
AC_DEFINE(HAVE_FAAD,1,[Define to use FAAD2 for AAC decoding])
else
AC_MSG_WARN([faad2 lib needed for MP4/AAC support -- disabling MP4/AAC support])