aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-30 19:43:25 +0100
committerMax Kellermann <max@duempel.org>2009-01-30 19:43:25 +0100
commit590082767530834ed3abff9009f9169dba4bd16f (patch)
tree8669fb2d7aac1f3081f3cc1dd10a5e06d3ee5e31 /configure.ac
parent5b85288664f6f45172bb812a739e9b0cc8f1e974 (diff)
downloadmpd-590082767530834ed3abff9009f9169dba4bd16f.tar.gz
mpd-590082767530834ed3abff9009f9169dba4bd16f.tar.xz
mpd-590082767530834ed3abff9009f9169dba4bd16f.zip
configure.ac: detect jack_set_info_function()
jack_set_info_function() is not provided by older libjack versions. Attempt to detect if it is available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3b0d233b..6f6711792 100644
--- a/configure.ac
+++ b/configure.ac
@@ -620,6 +620,16 @@ if test x$enable_jack = xyes; then
[enable_jack=no;AC_MSG_WARN([JACK not found -- disabling])])
fi
+if test x$enable_jack = xyes; then
+ # check whether jack_set_info_function() is available
+ old_LIBS=$LIBS
+ LIBS="$LIBS $JACK_LIBS"
+
+ AC_CHECK_FUNCS(jack_set_info_function)
+
+ LIBS=$old_LIBS
+fi
+
AM_CONDITIONAL(HAVE_JACK, test x$enable_jack = xyes)
if test x$enable_id3 = xyes; then