aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-18 18:39:12 +0100
committerMax Kellermann <max@duempel.org>2009-02-18 18:39:12 +0100
commit51c59f622872c7fb028c121cc74300de34a80783 (patch)
treee624baa4142fd9bb323544b58949bf2b56591186 /configure.ac
parent111c73e701e61316c7aef41bf4330759cfaba5e7 (diff)
downloadmpd-51c59f622872c7fb028c121cc74300de34a80783.tar.gz
mpd-51c59f622872c7fb028c121cc74300de34a80783.tar.xz
mpd-51c59f622872c7fb028c121cc74300de34a80783.zip
mp4ff: use faacDecInit2() to find the AAC track
Use faacDecInit2() instead of AudioSpecificConfig() to detect the AAC track in the MP4 file. This has a great advantage: it initializes the libfaad decoder, which the caller would normally do anyway - but now we can go without the AudioSpecificConfig() call. When decoder==NULL (called from mp4_tag_dup()), fall back to a mp4ff_get_track_type()==1 check, like other audio players do.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 0 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 61c821604..3b60f4b51 100644
--- a/configure.ac
+++ b/configure.ac
@@ -812,7 +812,6 @@ int main() {
])
fi
if test x$enable_aac = xyes; then
- AC_CHECK_TYPES(mp4AudioSpecificConfig,,,[#include <faad.h>])
AC_CHECK_MEMBERS([faacDecConfiguration.downMatrix,faacDecConfiguration.dontUpSampleImplicitSBR,faacDecFrameInfo.samplerate],,,[#include <faad.h>])
AC_DEFINE(HAVE_FAAD,1,[Define to use FAAD2 for AAC decoding])
else