aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-08-06 23:25:57 +0200
committerMax Kellermann <max@duempel.org>2013-08-06 23:32:21 +0200
commit47e16dbee3d43a8fac8e2337df442814ec6d036b (patch)
tree011c45b1d151425adaef1168fcf6ba7238d6e82a /configure.ac
parent66f678023f6e18dde9679d0a69565d6a50d09ed4 (diff)
downloadmpd-47e16dbee3d43a8fac8e2337df442814ec6d036b.tar.gz
mpd-47e16dbee3d43a8fac8e2337df442814ec6d036b.tar.xz
mpd-47e16dbee3d43a8fac8e2337df442814ec6d036b.zip
configure.ac: add option --enable-eventfd
Remove the runtime check for eventfd(), hard-code the feature once it's been selected at compile time. The class WakeFD is splitted into EventFD and EventPipe, using WakeFD as a macro diversion.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index edf29d215..556c50024 100644
--- a/configure.ac
+++ b/configure.ac
@@ -139,7 +139,8 @@ AC_SEARCH_LIBS([syslog], [bsd socket inet],
AC_SEARCH_LIBS([socket], [socket])
AC_SEARCH_LIBS([gethostbyname], [nsl])
-AC_CHECK_FUNCS(pipe2 accept4 eventfd)
+AC_CHECK_FUNCS(pipe2 accept4)
+MPD_OPTIONAL_FUNC(eventfd, USE_EVENTFD)
AC_SEARCH_LIBS([exp], [m],,
[AC_MSG_ERROR([exp() not found])])