aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-10-13 16:12:43 +0200
committerMax Kellermann <max@duempel.org>2009-10-13 16:12:43 +0200
commit4390d72b141304b8dfcdb374b428d3b4fae56237 (patch)
treea7c2132c621c04a1a7494a39b97489900e128539 /configure.ac
parent2bf740fc71438edcb2c89e722ee8c83beb560128 (diff)
downloadmpd-4390d72b141304b8dfcdb374b428d3b4fae56237.tar.gz
mpd-4390d72b141304b8dfcdb374b428d3b4fae56237.tar.xz
mpd-4390d72b141304b8dfcdb374b428d3b4fae56237.zip
configure.ac: require GLib 2.16
Accidently, MPD has been using several GLib 2.16 functions for a while, and nobody noticed yet. To simplify the code base, let's bump the minimum GLib version for MPD to 2.16. That version is old enough, and it's reasonable to expect users to have it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 917bda86b..885115971 100644
--- a/configure.ac
+++ b/configure.ac
@@ -128,8 +128,8 @@ dnl
dnl mandatory libraries
dnl
-PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.6 gthread-2.0],,
- [AC_MSG_ERROR([glib-2.6 is required])])
+PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.16 gthread-2.0],,
+ [AC_MSG_ERROR([glib-2.16 is required])])
dnl