aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-02 23:11:31 +0100
committerMax Kellermann <max@duempel.org>2009-03-02 23:11:31 +0100
commit4220e6b0adccf2f09a82fb85768b7aecc5744b6c (patch)
tree55509fd1eb5dcbad42a7f0c3af7a19107a2e9647 /configure.ac
parent9cd5b0af74b61967164598382e5ef66774e766a8 (diff)
downloadmpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.tar.gz
mpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.tar.xz
mpd-4220e6b0adccf2f09a82fb85768b7aecc5744b6c.zip
input_lastfm: new input plugin for last.fm radio
The lastfm input plugin enables MPD to play lastfm:// URLs. This plugin is not complete yet: it plays only the first song in the last.fm playlist, and the playlist parser isn't even implemented properly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5f5f70a10..1e1669085 100644
--- a/configure.ac
+++ b/configure.ac
@@ -253,6 +253,20 @@ if test x$enable_curl = xyes; then
fi
AM_CONDITIONAL(HAVE_CURL, test x$enable_curl = xyes)
+AC_ARG_ENABLE(lastfm,
+ AS_HELP_STRING([--enable-lastfm],
+ [enable support for last.fm radio (default: disable)]),,
+ [enable_lastfm=no])
+
+if test x$enable_lastfm = xyes; then
+ if test x$enable_curl != xyes; then
+ AC_MSG_ERROR([Cannot enable last.fm radio without curl])
+ fi
+
+ AC_DEFINE(ENABLE_LASTFM, 1, [Define when last.fm radio is enabled]),
+fi
+AM_CONDITIONAL(ENABLE_LASTFM, test x$enable_lastfm = xyes)
+
AC_ARG_ENABLE(mms,
AS_HELP_STRING([--enable-mms],
[enable the MMS protocol with libmms (default: disable)]),,