aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorR.Ramkumar <andyetitmoves@gmail.com>2006-07-04 22:07:34 +0000
committerEric Wong <normalperson@yhbt.net>2006-07-04 22:07:34 +0000
commit3e8009ffca5d435a708c08a7325e2dca075477ac (patch)
tree2c06ef828a8f84b43eacf8d2228c3e28b121506a /configure.ac
parentee8b70b5954a8821c1f59d84a14952c4ace36760 (diff)
downloadmpd-3e8009ffca5d435a708c08a7325e2dca075477ac.tar.gz
mpd-3e8009ffca5d435a708c08a7325e2dca075477ac.tar.xz
mpd-3e8009ffca5d435a708c08a7325e2dca075477ac.zip
configure.ac: fix configure failing with newer faad2
Patch-by: R.Ramkumar <andyetitmoves@gmail.com>: > MPD's configure seems to fail with newer versions of faad2 (Atleast > mine from CVS does, I don't know how long this has been a problem > for). MPD checks for faacDecInit2 which has been #define'd to > NeAACDecInit2, and hence AC_CHECK_LIB fails. I am enclosing a patch > which checks for the latter as a fallback. Hope that fixes things :) This looks reasonable, but I haven't tested it myself [normalperson] git-svn-id: https://svn.musicpd.org/mpd/trunk@4297 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 8f0ead775..7e84f7fcc 100644
--- a/configure.ac
+++ b/configure.ac
@@ -369,6 +369,10 @@ if test x$enable_aac = xyes; then
fi
if test x$enable_aac = xyes; then
AC_CHECK_LIB(faad,faacDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ if test x$enable_aac = xno; then
+ enable_aac=yes
+ AC_CHECK_LIB(faad,NeAACDecInit2,[MPD_LIBS="$MPD_LIBS $FAAD_LIBS";MPD_CFLAGS="$MPD_CFLAGS $FAAD_CFLAGS";MP4FF_SUBDIR="mp4ff";MP4FF_LIB="mp4ff/libmp4ff.la"],enable_aac=no)
+ fi
fi
if test x$enable_aac = xyes; then
AC_MSG_CHECKING(that FAAD2 uses buffer and bufferlen)