aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2008-11-07 17:21:21 +0100
committerMax Kellermann <max@duempel.org>2008-11-07 17:21:21 +0100
commit343f2ac3fc8ae6161d9586cee333fc13c794f937 (patch)
treef1c9718881ad629a7f16e2e3c0852d7339ddc408 /configure.ac
parent2172505f5cdef3ad63e5818af0d1acee83076eeb (diff)
downloadmpd-343f2ac3fc8ae6161d9586cee333fc13c794f937.tar.gz
mpd-343f2ac3fc8ae6161d9586cee333fc13c794f937.tar.xz
mpd-343f2ac3fc8ae6161d9586cee333fc13c794f937.zip
configure.ac: enable _ogg_common.c when flac is enabled
The build failed when the oggvorbis and oggflac decoders were disabled, because the flac decoder references a symbol from _ogg_common.c.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index fc071b273..2021e8b42 100644
--- a/configure.ac
+++ b/configure.ac
@@ -724,7 +724,7 @@ fi
AM_CONDITIONAL(HAVE_OGGFLAC, test x$enable_oggflac = xyes)
AM_CONDITIONAL(HAVE_FLAC_COMMON, test x$enable_flac = xyes || test x$enable_oggflac = xyes)
-AM_CONDITIONAL(HAVE_OGG_COMMON, test x$enable_oggvorbis = xyes || test x$enable_oggflac = xyes)
+AM_CONDITIONAL(HAVE_OGG_COMMON, test x$enable_oggvorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
if test x$enable_audiofile = xyes; then
PKG_CHECK_MODULES(AUDIOFILE, [audiofile >= 0.1.7],