aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorWarren Dukes <warren.dukes@gmail.com>2004-08-20 13:57:11 +0000
committerWarren Dukes <warren.dukes@gmail.com>2004-08-20 13:57:11 +0000
commit2a1fa4fd253d6e8fc50a6ee4bd9ccb6230da7145 (patch)
treeba2a025aa77c99fc933506f54a099e82dd6a40a3 /configure.ac
parent2afc2f8c0ddb16a986fd2910323c30a3a2cba360 (diff)
downloadmpd-2a1fa4fd253d6e8fc50a6ee4bd9ccb6230da7145.tar.gz
mpd-2a1fa4fd253d6e8fc50a6ee4bd9ccb6230da7145.tar.xz
mpd-2a1fa4fd253d6e8fc50a6ee4bd9ccb6230da7145.zip
shout configure/auto* stuff
git-svn-id: https://svn.musicpd.org/mpd/trunk@2059 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 617a048f7..c1bf7ffaa 100644
--- a/configure.ac
+++ b/configure.ac
@@ -32,6 +32,7 @@ fi
MPD_LIBS=""
AC_ARG_ENABLE(audio,[ --disable-audio disable support for playing],,enable_ao=yes)
+AC_ARG_ENABLE(shout,[ --disable-shout disable support for streaming through shout],,enable_shout=yes)
AC_ARG_ENABLE(iconv,[ --disable-iconv disable iconv support],,enable_iconv=yes)
AC_ARG_ENABLE(ipv6,[ --disable-ipv6 disable IPv6 support],,enable_ipv6=yes)
AC_ARG_ENABLE(alsa,[ --disable-alsa disable ALSA Mixer support],,enable_alsa=yes)
@@ -104,6 +105,10 @@ if test x$enable_ao = xyes; then
AC_DEFINE(HAVE_AUDIO, 1, [Define to play audio])
fi
+if test x$enable_shout = xyes; then
+ XIPH_PATH_SHOUT([AC_DEFINE(HAVE_SHOUT, 1, [Define to enable libshout support]) MPD_LIBS="$MPD_LIBS $SHOUT_LIBS" MPD_CFLAGS="$MPD_CFLAGS $SHOUT_CFLAGS"], enable_shout=no)
+fi
+
AC_CHECK_HEADER(sys/soundcard.h,enable_oss=yes,[AC_MSG_WARN(Soundcard headers not found -- disabling OSS mixer);enable_oss=no;AC_DEFINE(NO_OSS_MIXER,1,[Define to disable OSS mixer support])])
if test x$enable_alsa = xyes; then
@@ -528,6 +533,12 @@ else
echo "Playing audio .................disabled"
fi
+if test x$enable_shout = xyes; then
+ echo "Streaming through shout .......enabled"
+else
+ echo "Streaming through shout .......disabled"
+fi
+
if test x$enable_id3 = xyes; then
echo "ID3 tag support ...............enabled"
if test x$use_mpd_id3tag = xyes; then