aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2010-04-17 11:09:02 -0700
committerAvuton Olrich <avuton@gmail.com>2010-04-21 12:23:37 -0700
commit2834f7802f0c1db72ca1d4db905589493e27f2b0 (patch)
tree086714da4e52d40331db79e8c8f2cb43f5ea1fc3 /configure.ac
parentb135483abc85f14b14015d2ea66bababbb67abcc (diff)
downloadmpd-2834f7802f0c1db72ca1d4db905589493e27f2b0.tar.gz
mpd-2834f7802f0c1db72ca1d4db905589493e27f2b0.tar.xz
mpd-2834f7802f0c1db72ca1d4db905589493e27f2b0.zip
configure.ac: Move decoder minimum test to Post Decoder Plugins tests.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 21 insertions, 19 deletions
diff --git a/configure.ac b/configure.ac
index 0bc2255d3..4caf44efd 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1174,6 +1174,27 @@ AM_CONDITIONAL(ENABLE_WILDMIDI, test x$enable_wildmidi = xyes)
dnl ------------------------ Post Decoder Plugins Tests -----------------------
+if
+ test x$enable_aac = xno &&
+ test x$enable_audiofile = xno &&
+ test x$enable_ffmpeg = xno &&
+ test x$enable_flac = xno &&
+ test x$enable_fluidsynth = xno &&
+ test x$enable_mad = xno &&
+ test x$enable_mikmod = xno; then
+ test x$enable_modplug = xno &&
+ test x$enable_mp4 = xno &&
+ test x$enable_mpc = xno &&
+ test x$enable_mpg123 = xno &&
+ test x$enable_oggflac = xno &&
+ test x$enable_sidplay = xno &&
+ test x$enable_vorbis = xno &&
+ test x$enable_wavpack = xno &&
+ test x$enable_wildmidi = xno &&
+
+ AC_MSG_ERROR([No input plugins supported!])
+fi
+
AM_CONDITIONAL(HAVE_OGG_COMMON,
test x$enable_vorbis = xyes || test x$enable_oggflac = xyes || test x$enable_flac = xyes)
@@ -1455,25 +1476,6 @@ results(audiofile, [WAVE])
results(wavpack, [WavPack])
results(wildmidi, [WildMidi])
-if
- test x$enable_mad = xno &&
- test x$enable_mpg123 = xno &&
- test x$enable_vorbis = xno &&
- test x$enable_flac = xno &&
- test x$enable_oggflac = xno &&
- test x$enable_audiofile = xno &&
- test x$enable_aac = xno &&
- test x$enable_mpc = xno &&
- test x$enable_wavpack = xno &&
- test x$enable_ffmpeg = xno &&
- test x$enable_modplug = xno &&
- test x$enable_sidplay = xno &&
- test x$enable_fluidsynth = xno &&
- test x$enable_wildmidi = xno &&
- test x$enable_mp4 = xno &&
- test x$enable_mikmod = xno; then
- AC_MSG_ERROR([No input plugins supported!])
-fi
echo -en '\nOther features:\n\t'
results(lsr, [libsamplerate])