aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-01-04 15:31:06 +0100
committerMax Kellermann <max@duempel.org>2009-01-04 15:31:06 +0100
commit1cad0c5b1d864d90ee089a512445db52b6682de9 (patch)
treedb918ffa89e5bfd45300c00211cded6041803c27 /configure.ac
parent55b6fd2f0c9b49f980d669e49dc6e04cbf4a769a (diff)
downloadmpd-1cad0c5b1d864d90ee089a512445db52b6682de9.tar.gz
mpd-1cad0c5b1d864d90ee089a512445db52b6682de9.tar.xz
mpd-1cad0c5b1d864d90ee089a512445db52b6682de9.zip
configure.ac: detect libid3tag without pkg-config
libid3tag comes without a pkg-config file, and it is usually added by distribution packages. For those without .pc file, attempt to auto-detect the library with AC_CHECK_LIB.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 41dda0890..8b3937e46 100644
--- a/configure.ac
+++ b/configure.ac
@@ -544,9 +544,14 @@ fi
AM_CONDITIONAL(HAVE_JACK, test x$enable_jack = xyes)
if test x$enable_id3 = xyes; then
- PKG_CHECK_MODULES([ID3TAG], [id3tag],
- AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag]),
- enable_id3=no)
+ PKG_CHECK_MODULES([ID3TAG], [id3tag],,
+ AC_CHECK_LIB(id3tag, id3_file_open,
+ [ID3TAG_LIBS="-lid3tag -lz" ID3TAG_CFLAGS=""],
+ enable_id3tag=no))
+fi
+
+if test x$enable_id3 = xyes; then
+ AC_DEFINE(HAVE_ID3TAG, 1, [Define to use id3tag])
fi
AM_CONDITIONAL(HAVE_ID3TAG, test x$enable_id3 = xyes)