aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorKalle Wallin <kaw@linux.se>2006-03-28 08:09:51 +0000
committerKalle Wallin <kaw@linux.se>2006-03-28 08:09:51 +0000
commit1525d2bba9555fee56de49eac583c129363f5407 (patch)
tree898a6b575eedc2c0cb5849633230ba6332547712 /configure.ac
parentfbc94537425e7238c5981b6d3821f2f5b0163c2e (diff)
downloadmpd-1525d2bba9555fee56de49eac583c129363f5407.tar.gz
mpd-1525d2bba9555fee56de49eac583c129363f5407.tar.xz
mpd-1525d2bba9555fee56de49eac583c129363f5407.zip
check for recv/send/gethostbyname/socket/connect (solaris)
git-svn-id: https://svn.musicpd.org/ncmpc/trunk@3959 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 323a24298..9cda77546 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,6 +51,21 @@ dnl
dnl Check for libraries
dnl
+dnl Try to find the socket functions
+AC_CHECK_FUNC([socket],
+ [],
+ [AC_CHECK_LIB([socket],[socket],[LIBS="$LIBS -lsocket"],
+ [AC_MSG_ERROR(No UNIX socket API found)])
+ ])
+
+dnl Try to find the gethostbyname functions
+AC_CHECK_FUNC([gethostbyname],
+ [],
+ [AC_CHECK_LIB([nsl],[gethostbyname],[LIBS="$LIBS -lnsl"],
+ [AC_MSG_ERROR(No UNIX gethostbyname API found)])
+ ])
+
+
dnl ncurses
ncurses=ncursesw
AC_ARG_WITH([ncurses],