aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-02-09 22:22:06 +0100
committerMax Kellermann <max@duempel.org>2009-02-09 22:22:06 +0100
commit14b57e5b096a21e625920b612069db533a19bb9d (patch)
tree02267b76d493118891b3b624805d32087920dd26 /configure.ac
parente5da9e459dc407283daeb0bd483f4d9d12d72de4 (diff)
downloadmpd-14b57e5b096a21e625920b612069db533a19bb9d.tar.gz
mpd-14b57e5b096a21e625920b612069db533a19bb9d.tar.xz
mpd-14b57e5b096a21e625920b612069db533a19bb9d.zip
configure.ac: define HAVE_FFMPEG after all checks
Don't define HAVE_FFMPEG if the ffmpeg libraries were found via pkg-config, but ffmpeg support was disabled because avcodec_decode_audio2() is not available.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 5 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index a68d070ed..cbdd2a618 100644
--- a/configure.ac
+++ b/configure.ac
@@ -784,8 +784,7 @@ fi
AM_CONDITIONAL(HAVE_MIKMOD, test x$enable_mod = xyes)
if test x$enable_ffmpeg = xyes; then
- PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],
- AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+ PKG_CHECK_MODULES(FFMPEG, [libavformat libavcodec libavutil],,
enable_ffmpeg=no)
fi
@@ -808,6 +807,10 @@ if test x$enable_ffmpeg = xyes; then
CPPCFLAGS=$old_CPPFLAGS
fi
+if test x$enable_ffmpeg = xyes; then
+ AC_DEFINE(HAVE_FFMPEG, 1, [Define for FFMPEG support]),
+fi
+
AM_CONDITIONAL(HAVE_FFMPEG, test x$enable_ffmpeg = xyes)
case $with_zeroconf in