aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAvuton Olrich <avuton@gmail.com>2009-03-15 12:37:24 -0700
committerAvuton Olrich <avuton@gmail.com>2009-03-15 12:37:24 -0700
commit04b092bbfe418bd38e782add174b08fad6f8058c (patch)
tree25e1f80c0df23cbeb440a11eb9c53835e583e09f /configure.ac
parent7b5c658f7ef1f97e1ae12054e6e3fcc89d5e050d (diff)
downloadmpd-04b092bbfe418bd38e782add174b08fad6f8058c.tar.gz
mpd-04b092bbfe418bd38e782add174b08fad6f8058c.tar.xz
mpd-04b092bbfe418bd38e782add174b08fad6f8058c.zip
configure: add shout autoconf argument.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index cf8d33c36..58a1ad15d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -588,6 +588,11 @@ esac
AM_CONDITIONAL(HAVE_OSX, test x$enable_osx = xyes)
+AC_ARG_ENABLE(shout,
+ AS_HELP_STRING([--enable-shout],
+ [enables the shoutcast streaming output (default: disable)]),,
+ [enable_shout=no])
+
if test x$enable_oggvorbis_encoder = xyes || test x$enable_lame_encoder = xyes; then
PKG_CHECK_MODULES([SHOUT], [shout],,
[enable_oggvorbis_encoder=no; enable_lame_encoder=no;