aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJ. Alexander Treuman <jat@spatialrift.net>2006-12-17 21:30:24 +0000
committerJ. Alexander Treuman <jat@spatialrift.net>2006-12-17 21:30:24 +0000
commit0435a8c7c1e53a0f97358097979680de94cb985b (patch)
tree983ce5a782e91e9038ce3f799c0c6803652fea59 /configure.ac
parent4479ece74d8a85359a5ced6431a6b3d5f0d2e0c5 (diff)
downloadmpd-0435a8c7c1e53a0f97358097979680de94cb985b.tar.gz
mpd-0435a8c7c1e53a0f97358097979680de94cb985b.tar.xz
mpd-0435a8c7c1e53a0f97358097979680de94cb985b.zip
Cleaning up the JACK/PulseAudio configure magic to be more consistent with
each other. Hopefully this will also fix a bug where --enable-jack --disable-pulse would result in both JACK and PulseAudio being disabled. git-svn-id: https://svn.musicpd.org/mpd/trunk@5141 09075e82-0dd4-0310-85a5-a0d7c8717e4f
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 3242d8b97..76b05baa4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,7 +179,7 @@ fi
if test x$enable_pulse = xyes; then
PKG_CHECK_MODULES([PULSE], [libpulse-simple],
- [enable_pulse=yes;AC_DEFINE([HAVE_PULSE], 1, [Define to enable PulseAudio])] MPD_LIBS="$MPD_LIBS $PULSE_LIBS" MPD_CFLAGS="$MPD_CFLAGS $PULSE_CFLAGS",
+ [enable_pulse=yes;AC_DEFINE([HAVE_PULSE], 1, [Define to enable PulseAudio support])] MPD_LIBS="$MPD_LIBS $PULSE_LIBS" MPD_CFLAGS="$MPD_CFLAGS $PULSE_CFLAGS",
[enable_pulse=no;AC_MSG_WARN([PulseAudio not found -- disabling])])
fi
@@ -191,12 +191,10 @@ if test x$enable_alsa = xyes; then
AM_PATH_ALSA(0.9.0,[AC_DEFINE(HAVE_ALSA,1,[Define to enable ALSA support]) MPD_LIBS="$MPD_LIBS $ALSA_LIBS" MPD_CFLAGS="$MPD_CFLAGS $ALSA_CFLAGS"],enable_alsa=no)
fi
-if test "x$enable_jack" = "xyes"; then
- PKG_CHECK_MODULES(JACK, [jack >= 0.4],
- [AC_DEFINE(HAVE_JACK,1,[Define to enable JACK support])
- MPD_LIBS="$MPD_LIBS $JACK_LIBS"
- MPD_CFLAGS="$MPD_CFLAGS $JACK_CFLAGS"],
- [enable_jack=no])
+if test x$enable_jack = xyes; then
+ PKG_CHECK_MODULES([JACK], [jack >= 0.4],
+ [enable_jack=yes;AC_DEFINE([HAVE_JACK], 1, [Define to enable JACK support])] MPD_LIBS="$MPD_LIBS $JACK_LIBS" MPD_CFLAGS="$MPD_CFLAGS $JACK_CFLAGS",
+ [enable_jack=no;AC_MSG_WARN([JACK not found -- disabling])])
fi
if test x$enable_iconv = xyes; then