aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-06-30 10:51:07 +0200
committerMax Kellermann <max@duempel.org>2010-06-30 10:51:07 +0200
commit002b283433dd70db8c89cb2c465af6a4b30fab89 (patch)
treeca0907b0ec67c7b25d388dcdbdee3ef25f3b0d97 /configure.ac
parent5a2820ca3dd73659996f8205687f5c91761eac93 (diff)
downloadmpd-002b283433dd70db8c89cb2c465af6a4b30fab89.tar.gz
mpd-002b283433dd70db8c89cb2c465af6a4b30fab89.tar.xz
mpd-002b283433dd70db8c89cb2c465af6a4b30fab89.zip
configure.ac: check ffmpeg version number with pkg-config
Replace the check for avcodec_decode_audio2(), assume it's present in libavcodec version 51.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index c1d3bcd53..3bf956b69 100644
--- a/configure.ac
+++ b/configure.ac
@@ -725,18 +725,10 @@ AM_CONDITIONAL(HAVE_FAAD, test x$enable_aac = xyes)
AM_CONDITIONAL(HAVE_MP4, test x$enable_mp4 = xyes)
dnl ---------------------------------- ffmpeg ---------------------------------
-MPD_AUTO_PKG(ffmpeg, FFMPEG, [libavformat libavcodec libavutil],
+MPD_AUTO_PKG(ffmpeg, FFMPEG, [libavformat >= 52 libavcodec >= 51 libavutil >= 49],
[ffmpeg decoder library], [libavformat+libavcodec+libavutil not found])
if test x$enable_ffmpeg = xyes; then
- old_LIBS=$LIBS
- LIBS="$LIBS $FFMPEG_LIBS"
- AC_CHECK_LIB(avcodec, avcodec_decode_audio2,,
- enable_ffmpeg=no)
- LIBS=$old_LIBS
-fi
-
-if test x$enable_ffmpeg = xyes; then
# prior to ffmpeg svn12865, you had to specify include files
# without path prefix
old_CPPCFLAGS=$CPPFLAGS