aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-06 10:01:47 +0200
committerMax Kellermann <max@duempel.org>2009-07-06 10:01:47 +0200
commite47bdfe8e6f7da67c9714db7e650fa6a925f7847 (patch)
tree67f466706685a053da1549a9702ef0b0caa52715 /Makefile.am
parentcd9c0a6b3e0a113d873483d214e1be1c37301b06 (diff)
downloadmpd-e47bdfe8e6f7da67c9714db7e650fa6a925f7847.tar.gz
mpd-e47bdfe8e6f7da67c9714db7e650fa6a925f7847.tar.xz
mpd-e47bdfe8e6f7da67c9714db7e650fa6a925f7847.zip
output: attach a filter chain to each audio_output
This patch adds initial filter support for audio outputs. Each audio output gets a "filter" attribute, which is used by ao_play_chunk(). The PCM conversion is now performed by convert_filter_plugin. audio_output.convert_state has been removed.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 11397ac3d..d7551c11f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -739,6 +739,8 @@ test_run_output_SOURCES = test/run_output.c \
src/mixer_api.c \
src/mixer_control.c \
$(MIXER_SRC) \
+ src/filter_plugin.c src/filter/chain_filter_plugin.c \
+ src/filter/convert_filter_plugin.c \
$(OUTPUT_SRC)
test_read_mixer_CPPFLAGS = $(AM_CPPFLAGS) \