aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-03-14 15:26:36 +0100
committerMax Kellermann <max@duempel.org>2009-03-14 15:26:36 +0100
commite12140cfce88985f9fcecb93214a94a0b9c33e7f (patch)
tree3e5c213af02c782e67f0a0fd902c63382e2eb56a /Makefile.am
parent456201fa222ab208aba45fa2d700a56f04876886 (diff)
downloadmpd-e12140cfce88985f9fcecb93214a94a0b9c33e7f.tar.gz
mpd-e12140cfce88985f9fcecb93214a94a0b9c33e7f.tar.xz
mpd-e12140cfce88985f9fcecb93214a94a0b9c33e7f.zip
pcm_resample: choose the fallback resampler at runtime
Even if libsamplerate support is enabled, compile the fallback resampler. When the user specifies the option "samplerate_converter=internal", it is chosen in favor of libsamplerate. This may help users with a weak FPU who don't want to compile a custom MPD from source, because the fallback resampler does not use floating point operations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 1 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 508cba28b..9c0245923 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -198,6 +198,7 @@ src_mpd_SOURCES = \
src/pcm_channels.c \
src/pcm_format.c \
src/pcm_resample.c \
+ src/pcm_resample_fallback.c \
src/pcm_dither.c \
src/permission.c \
src/player_thread.c \
@@ -240,8 +241,6 @@ endif
if HAVE_LIBSAMPLERATE
src_mpd_SOURCES += src/pcm_resample_libsamplerate.c
-else
-src_mpd_SOURCES += src/pcm_resample_fallback.c
endif
if HAVE_ID3TAG