aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2013-10-18 09:16:55 +0200
committerMax Kellermann <max@duempel.org>2013-10-18 09:16:55 +0200
commitd1c401fe7a637cdea728c8c2860d47c3d1e0efa0 (patch)
treed8a871d252acdca07dd98fee6ee5edb9f150ad43 /Makefile.am
parent964aa42b0479efac9a811ff071f27f28a27a6ede (diff)
downloadmpd-d1c401fe7a637cdea728c8c2860d47c3d1e0efa0.tar.gz
mpd-d1c401fe7a637cdea728c8c2860d47c3d1e0efa0.tar.xz
mpd-d1c401fe7a637cdea728c8c2860d47c3d1e0efa0.zip
ZeroconfAvahi: integrate into the EventLoop
Finally fixes the regression by commit c1f4f1fd.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 67e5b2454..45f257182 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -724,7 +724,9 @@ src_mpd_SOURCES += \
src/ZeroconfGlue.cxx src/ZeroconfGlue.hxx
if HAVE_AVAHI
-src_mpd_SOURCES += src/ZeroconfAvahi.cxx src/ZeroconfAvahi.hxx
+src_mpd_SOURCES += \
+ src/AvahiPoll.cxx src/AvahiPoll.hxx \
+ src/ZeroconfAvahi.cxx src/ZeroconfAvahi.hxx
endif
if HAVE_BONJOUR
@@ -1346,7 +1348,7 @@ test_software_volume_LDADD = \
test_run_avahi_SOURCES = \
src/Log.cxx \
- src/ZeroconfAvahi.cxx \
+ src/ZeroconfAvahi.cxx src/AvahiPoll.cxx \
test/ShutdownHandler.cxx test/ShutdownHandler.hxx \
test/run_avahi.cxx
test_run_avahi_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -1354,6 +1356,7 @@ test_run_avahi_CPPFLAGS = $(AM_CPPFLAGS) \
test_run_avahi_LDADD = \
libevent.a \
libsystem.a \
+ $(GLIB_LIBS) \
$(AVAHI_LIBS)
test_run_normalize_SOURCES = test/run_normalize.cxx \