aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2012-10-02 10:56:44 +0200
committerMax Kellermann <max@duempel.org>2012-10-02 10:59:56 +0200
commitcbdd042adc8131c4ef890195447760d229eb1f87 (patch)
treef32b528e955b7bdf468168b8c490052bd33a702a /Makefile.am
parenta9419da09c27986708002fcb6a9032371eb1ce2b (diff)
downloadmpd-cbdd042adc8131c4ef890195447760d229eb1f87.tar.gz
mpd-cbdd042adc8131c4ef890195447760d229eb1f87.tar.xz
mpd-cbdd042adc8131c4ef890195447760d229eb1f87.zip
decoder/flac: use C++ compiler
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index f917a2330..d0c8b48e4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -98,8 +98,6 @@ mpd_headers = \
src/gcc.h \
src/decoder_list.h \
src/decoder_print.h \
- src/decoder/flac_metadata.h \
- src/decoder/flac_pcm.h \
src/decoder/pcm_decoder_plugin.h \
src/input_init.h \
src/input_plugin.h \
@@ -620,10 +618,11 @@ endif
if HAVE_FLAC
libdecoder_plugins_a_SOURCES += \
- src/decoder/flac_metadata.c \
- src/decoder/flac_pcm.c \
- src/decoder/flac_common.c src/decoder/flac_common.h \
- src/decoder/flac_decoder_plugin.c
+ src/decoder/FLACMetaData.cxx src/decoder/FLACMetaData.hxx \
+ src/decoder/FLAC_PCM.cxx src/decoder/FLAC_PCM.hxx \
+ src/decoder/FLACCommon.cxx src/decoder/FLACCommon.hxx \
+ src/decoder/FLACDecoderPlugin.cxx \
+ src/decoder/FLACDecoderPlugin.h
endif
if HAVE_AUDIOFILE
@@ -1145,7 +1144,7 @@ test_dump_playlist_SOURCES = test/dump_playlist.c \
if HAVE_FLAC
test_dump_playlist_SOURCES += \
src/replay_gain_info.c \
- src/decoder/flac_metadata.c
+ src/decoder/FLACMetaData.cxx
endif
test_run_decoder_LDADD = \