aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-12-29 23:55:40 +0100
committerMax Kellermann <max@duempel.org>2009-12-29 23:55:40 +0100
commitc88f95a2ea1d089501bed84c085acd7312f7dc2a (patch)
treea413d715313a8f349889a893141fdbc2fa1bda92 /Makefile.am
parentc7d099c75736664867914fd5013a0a844cd23adc (diff)
downloadmpd-c88f95a2ea1d089501bed84c085acd7312f7dc2a.tar.gz
mpd-c88f95a2ea1d089501bed84c085acd7312f7dc2a.tar.xz
mpd-c88f95a2ea1d089501bed84c085acd7312f7dc2a.zip
input/rewind: new input_stream wrapper to allow stream rewinding
This replaces the rewinding buffer code from the CURL input plugin. It is more generic, and allows rewinding even when the server sends Icy-Metadata (which would have been too difficult to implement within the CURL plugin). This is a rather complex patch for the stable branch (v0.15.x), but it fixes a serious problem: the "vorbis" decoder plugin was unable to play streams with Icy-Metadata, because it couldn't rewind the stream after detecting the codec (Vorbis vs. FLAC).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cd5d406c2..d9b01f111 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,6 +75,7 @@ mpd_headers = \
src/input_stream.h \
src/input/file_input_plugin.h \
src/input/curl_input_plugin.h \
+ src/input/rewind_input_plugin.h \
src/input/lastfm_input_plugin.h \
src/input/mms_input_plugin.h \
src/icy_server.h \
@@ -467,7 +468,9 @@ INPUT_SRC = \
src/input/file_input_plugin.c
if HAVE_CURL
-INPUT_SRC += src/input/curl_input_plugin.c src/icy_metadata.c
+INPUT_SRC += src/input/curl_input_plugin.c \
+ src/input/rewind_input_plugin.c \
+ src/icy_metadata.c
endif
if ENABLE_LASTFM