aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-27 09:29:34 +0100
committerMax Kellermann <max@duempel.org>2014-01-27 09:29:34 +0100
commitc01282a322f13055cff9f68464b3b1750e59ee4f (patch)
tree163873a695d26f2795aed296c9e8d597aa017102 /Makefile.am
parent0e3f18ed70e8a508cc0c7ce5f24220ae2e612ccb (diff)
downloadmpd-c01282a322f13055cff9f68464b3b1750e59ee4f.tar.gz
mpd-c01282a322f13055cff9f68464b3b1750e59ee4f.tar.xz
mpd-c01282a322f13055cff9f68464b3b1750e59ee4f.zip
Makefile.am: remove "sparse" rule
We're C++, and sparse understands only plain C.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am20
1 files changed, 0 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index e21a1f920..2aa0614f5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1188,26 +1188,6 @@ systemdsystemunit_DATA = \
systemd/mpd.service
endif
-#
-# Sparse code analysis
-#
-# sparse is a semantic parser
-# URL: git://www.kernel.org/pub/scm/devel/sparse/sparse.git
-#
-
-SPARSE = sparse
-SPARSE_FLAGS =
-SPARSE_CPPFLAGS = $(DEFAULT_INCLUDES) \
- -I$(shell $(CC) -print-file-name=include) \
- -I$(shell $(CC) -print-file-name=include-fixed)
-SPARSE_CPPFLAGS += -D__SCHAR_MAX__=127 -D__SHRT_MAX__=32767 \
- -D__INT_MAX__=2147483647 -D__LONG_MAX__=2147483647
-SPARSE_SRC = $(addprefix $(top_srcdir)/,$(filter %.c,$(src_mpd_SOURCES)))
-sparse-check:
- $(SPARSE) -I. $(src_mpd_CFLAGS) $(src_mpd_CPPFLAGS) $(SPARSE_FLAGS) $(SPARSE_CPPFLAGS) $(SPARSE_SRC)
-
-.PHONY: sparse-check
-
#
# Test programs