aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Kagstrom <simon.kagstrom@gmail.com>2011-03-27 08:41:40 +0200
committerMax Kellermann <max@duempel.org>2011-03-29 17:01:16 +0200
commitbe798998bf44f740943cf82f6edb6d3616a8606a (patch)
tree79a94f63d01cb73df64e94313f16ffff032221c9 /Makefile.am
parentc3b425d570c8023e256a64a31e8c74afb8efe2c5 (diff)
downloadmpd-be798998bf44f740943cf82f6edb6d3616a8606a.tar.gz
mpd-be798998bf44f740943cf82f6edb6d3616a8606a.tar.xz
mpd-be798998bf44f740943cf82f6edb6d3616a8606a.zip
build: Add despotify to build system
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 64c474358..7251f769f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -109,7 +109,9 @@ mpd_headers = \
src/input/curl_input_plugin.h \
src/input/rewind_input_plugin.h \
src/input/mms_input_plugin.h \
+ src/input/despotify_input_plugin.h \
src/input/cdio_paranoia_input_plugin.h \
+ src/despotify_utils.h \
src/text_file.h \
src/text_input_stream.h \
src/icy_server.h \
@@ -181,6 +183,7 @@ mpd_headers = \
src/playlist/asx_playlist_plugin.h \
src/playlist/rss_playlist_plugin.h \
src/playlist/lastfm_playlist_plugin.h \
+ src/playlist/despotify_playlist_plugin.h \
src/playlist/cue_playlist_plugin.h \
src/playlist/flac_playlist_plugin.h \
src/poison.h \
@@ -361,6 +364,11 @@ src_mpd_SOURCES = \
src/stored_playlist.c \
src/timer.c
+if ENABLE_DESPOTIFY
+src_mpd_SOURCES += \
+ src/despotify_utils.c
+endif
+
if ENABLE_INOTIFY
src_mpd_SOURCES += \
src/inotify_source.c \
@@ -660,6 +668,10 @@ if ENABLE_MMS
INPUT_SRC += src/input/mms_input_plugin.c
endif
+if ENABLE_DESPOTIFY
+INPUT_SRC += src/input/despotify_input_plugin.c
+endif
+
OUTPUT_CFLAGS = \
$(AO_CFLAGS) \
@@ -802,6 +814,10 @@ if ENABLE_LASTFM
PLAYLIST_SRC += src/playlist/lastfm_playlist_plugin.c
endif
+if ENABLE_DESPOTIFY
+PLAYLIST_SRC += src/playlist/despotify_playlist_plugin.c
+endif
+
if HAVE_CUE
PLAYLIST_SRC += src/playlist/cue_playlist_plugin.c
endif
@@ -995,6 +1011,17 @@ if HAVE_LIBSAMPLERATE
test_run_filter_SOURCES += src/pcm_resample_libsamplerate.c
endif
+if ENABLE_DESPOTIFY
+test_read_tags_SOURCES += \
+ src/despotify_utils.c
+test_run_input_SOURCES += \
+ src/despotify_utils.c
+test_dump_playlist_SOURCES += \
+ src/despotify_utils.c
+test_run_decoder_SOURCES += \
+ src/despotify_utils.c
+endif
+
if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.c \