aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-10-13 18:53:33 +0200
committerMax Kellermann <max@duempel.org>2009-10-13 18:53:33 +0200
commita93ffdd1bed1885740f0a28bc649a9db9a7969e4 (patch)
tree855c12d75f8bc7df21ff7438594de9ae1657ac13 /Makefile.am
parent319149254d220861c76922be1f2fa8d00722da92 (diff)
downloadmpd-a93ffdd1bed1885740f0a28bc649a9db9a7969e4.tar.gz
mpd-a93ffdd1bed1885740f0a28bc649a9db9a7969e4.tar.xz
mpd-a93ffdd1bed1885740f0a28bc649a9db9a7969e4.zip
command: "load" supports remote playlists (m3u, xspf, lastfm://)
This patch integrates the playlist plugin API to the MPD core. We'll be able to do much more in the future with that API, that's just the beginning.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 03f0da990..c9bc70595 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -138,6 +138,7 @@ mpd_headers = \
src/playlist_state.h \
src/playlist_plugin.h \
src/playlist_list.h \
+ src/playlist_queue.h \
src/playlist/m3u_playlist_plugin.h \
src/playlist/xspf_playlist_plugin.h \
src/playlist/lastfm_playlist_plugin.h \
@@ -260,6 +261,7 @@ src_mpd_SOURCES = \
src/playlist_print.c \
src/playlist_save.c \
src/playlist_state.c \
+ src/playlist_queue.c \
src/queue.c \
src/queue_print.c \
src/queue_save.c \