aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-09-11 19:24:52 +0200
committerMax Kellermann <max@duempel.org>2014-09-11 19:26:58 +0200
commita464dc681a64514ad7b8b8dbb7e4c64ea0561396 (patch)
tree7cd84bd8fcd394f73920d46a9628b79450f40cb3 /Makefile.am
parentaf384d9aa6f216d3c5b890e3bd52140536c09686 (diff)
parenteaf675dc92fbe0143fdc0e9c4234bd78a889decf (diff)
downloadmpd-a464dc681a64514ad7b8b8dbb7e4c64ea0561396.tar.gz
mpd-a464dc681a64514ad7b8b8dbb7e4c64ea0561396.tar.xz
mpd-a464dc681a64514ad7b8b8dbb7e4c64ea0561396.zip
Merge tag 'v0.18.14'
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e3b871e7..9e04def44 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1458,6 +1458,7 @@ C_TESTS = \
test/test_rewind \
test/test_mixramp \
test/test_pcm \
+ test/test_protocol \
test/test_queue_priority
if ENABLE_CURL
@@ -2035,6 +2036,16 @@ test_test_translate_song_LDADD = \
endif
+test_test_protocol_SOURCES = \
+ src/protocol/ArgParser.cxx \
+ test/test_protocol.cxx
+test_test_protocol_CPPFLAGS = $(AM_CPPFLAGS) $(CPPUNIT_CFLAGS) -DCPPUNIT_HAVE_RTTI=0
+test_test_protocol_CXXFLAGS = $(AM_CXXFLAGS) -Wno-error=deprecated-declarations
+test_test_protocol_LDADD = \
+ libsystem.a \
+ libutil.a \
+ $(CPPUNIT_LIBS)
+
test_test_queue_priority_SOURCES = \
src/queue/Queue.cxx \
src/DetachedSong.cxx \