aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-11-01 15:37:16 +0100
committerMax Kellermann <max@duempel.org>2009-11-01 15:37:16 +0100
commit9bcfd3a47da540abeb2da06471cf2fa11c14db49 (patch)
tree37cfca02bd797fe16329717d036c05dee07a147a /Makefile.am
parent451f932d80f5b695adb59e293391d17c9b996fb8 (diff)
downloadmpd-9bcfd3a47da540abeb2da06471cf2fa11c14db49.tar.gz
mpd-9bcfd3a47da540abeb2da06471cf2fa11c14db49.tar.xz
mpd-9bcfd3a47da540abeb2da06471cf2fa11c14db49.zip
text_file: allocate line buffers dynamically
Use a single GString buffer object in all functions loading the database. Enlarge it automatically for long lines. This eliminates the maximum line length for tag values. There is still an upper limit of 512 kB to prevent denial of service, but that's reasonable I guess.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4cbe6774d..d7167a4cc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -88,6 +88,7 @@ mpd_headers = \
src/input/file_input_plugin.h \
src/input/curl_input_plugin.h \
src/input/mms_input_plugin.h \
+ src/text_file.h \
src/text_input_stream.h \
src/icy_server.h \
src/icy_metadata.h \
@@ -285,6 +286,7 @@ src_mpd_SOURCES = \
src/tag_print.c \
src/tag_save.c \
src/tokenizer.c \
+ src/text_file.c \
src/text_input_stream.c \
src/strset.c \
src/uri.c \