aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2014-01-26 13:02:49 +0100
committerMax Kellermann <max@duempel.org>2014-01-26 13:04:14 +0100
commit8c5ea7ec557d0ffdbd6fb96ea4e76d6ce177ac1b (patch)
tree978ca901fac81ea9f4f7cbe38763bdafe59d8983 /Makefile.am
parent412d1b0a01d37784b28ff39754dce64c9f5efca6 (diff)
downloadmpd-8c5ea7ec557d0ffdbd6fb96ea4e76d6ce177ac1b.tar.gz
mpd-8c5ea7ec557d0ffdbd6fb96ea4e76d6ce177ac1b.tar.xz
mpd-8c5ea7ec557d0ffdbd6fb96ea4e76d6ce177ac1b.zip
Makefile.am: add DespotifyUtils.cxx to libinput.a and libplaylist_plugins.a
Simplifies test program rules.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 6 insertions, 20 deletions
diff --git a/Makefile.am b/Makefile.am
index 21af71d0d..f0b97f429 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -230,12 +230,6 @@ src_mpd_DEPENDENCIES = src/win32/mpd_win32_rc.$(OBJEXT)
src_mpd_LDFLAGS = -Wl,src/win32/mpd_win32_rc.$(OBJEXT)
endif
-if ENABLE_DESPOTIFY
-src_mpd_SOURCES += \
- src/lib/despotify/DespotifyUtils.cxx \
- src/lib/despotify/DespotifyUtils.hxx
-endif
-
if ENABLE_INOTIFY
src_mpd_SOURCES += \
src/db/update/InotifyDomain.cxx src/db/update/InotifyDomain.hxx \
@@ -921,6 +915,8 @@ endif
if ENABLE_DESPOTIFY
libinput_a_SOURCES += \
+ src/lib/despotify/DespotifyUtils.cxx \
+ src/lib/despotify/DespotifyUtils.hxx \
src/input/plugins/DespotifyInputPlugin.cxx \
src/input/plugins/DespotifyInputPlugin.hxx
endif
@@ -1114,8 +1110,10 @@ PLAYLIST_LIBS = \
if ENABLE_DESPOTIFY
libplaylist_plugins_a_SOURCES += \
- src/playlist/plugins/DespotifyPlaylistPlugin.cxx \
- src/playlist/plugins/DespotifyPlaylistPlugin.hxx
+ src/lib/despotify/DespotifyUtils.cxx \
+ src/lib/despotify/DespotifyUtils.hxx \
+ src/playlist/plugins/DespotifyPlaylistPlugin.cxx \
+ src/playlist/plugins/DespotifyPlaylistPlugin.hxx
endif
if ENABLE_SOUNDCLOUD
@@ -1350,10 +1348,6 @@ test_visit_archive_SOURCES = test/visit_archive.cxx \
src/IOThread.cxx \
src/input/InputStream.cxx
-if ENABLE_DESPOTIFY
-test_visit_archive_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-endif
-
endif
test_dump_text_file_LDADD = \
@@ -1477,14 +1471,6 @@ test_run_filter_SOURCES = test/run_filter.cxx \
src/ReplayGainInfo.cxx \
src/AudioCompress/compress.c
-if ENABLE_DESPOTIFY
-test_read_tags_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-test_run_input_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-test_dump_text_file_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-test_dump_playlist_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-test_run_decoder_SOURCES += src/lib/despotify/DespotifyUtils.cxx
-endif
-
if ENABLE_ENCODER
noinst_PROGRAMS += test/run_encoder
test_run_encoder_SOURCES = test/run_encoder.cxx \