aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2010-10-03 21:07:55 +0200
committerMax Kellermann <max@duempel.org>2010-10-27 21:25:41 +0200
commit75f4772ba2584a3d533ee11fb210201d45f64bb6 (patch)
treefd9c9f6e3c534419ce03d13d7854b5979b6c0c84 /Makefile.am
parentfe1b626f760d5c5e0726befb1c243f4a901613a6 (diff)
downloadmpd-75f4772ba2584a3d533ee11fb210201d45f64bb6.tar.gz
mpd-75f4772ba2584a3d533ee11fb210201d45f64bb6.tar.xz
mpd-75f4772ba2584a3d533ee11fb210201d45f64bb6.zip
output: new output plugin "ffado"
Using libffado, to play on firewire audio devices. Warning: this plugin was not tested successfully. I just couldn't keep libffado2 from crashing. Use at your own risk. For details, see my Debian bug reports: http://bugs.debian.org/601657 http://bugs.debian.org/601659
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8f126676b..92a2a9f55 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -640,6 +640,7 @@ endif
OUTPUT_CFLAGS = \
$(AO_CFLAGS) \
$(ALSA_CFLAGS) \
+ $(FFADO_CFLAGS) \
$(JACK_CFLAGS) \
$(OPENAL_CFLAGS) \
$(PULSE_CFLAGS) \
@@ -649,6 +650,7 @@ OUTPUT_LIBS = \
$(LIBWRAP_LDFLAGS) \
$(AO_LIBS) \
$(ALSA_LIBS) \
+ $(FFADO_LIBS) \
$(JACK_LIBS) \
$(OPENAL_LIBS) \
$(PULSE_LIBS) \
@@ -681,6 +683,10 @@ OUTPUT_SRC += src/output/alsa_plugin.c
MIXER_SRC += src/mixer/alsa_mixer_plugin.c
endif
+if ENABLE_FFADO_OUTPUT
+OUTPUT_SRC += src/output/ffado_output_plugin.c
+endif
+
if HAVE_AO
OUTPUT_SRC += src/output/ao_plugin.c
endif