aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2009-07-06 21:52:15 +0200
committerMax Kellermann <max@duempel.org>2009-07-06 21:52:15 +0200
commit5d74b1efefb5d992096c2cdfeceb8281114bbd0c (patch)
treeac5a98cb25b0bd8a96e50f234bfa60bc8cf9b4c2 /Makefile.am
parentd3b5574d7aac0a7f2d4eb785facfad9f37c15dd5 (diff)
downloadmpd-5d74b1efefb5d992096c2cdfeceb8281114bbd0c.tar.gz
mpd-5d74b1efefb5d992096c2cdfeceb8281114bbd0c.tar.xz
mpd-5d74b1efefb5d992096c2cdfeceb8281114bbd0c.zip
mixer/software: new mixer which controls filter/volume
This mixer plugin may be used instead of the traditional global software mixer. It integrates with the "volume" filter plugin, and can control the software volume of an audio output which has no hardware mixer.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index d7551c11f..c37a6cca8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -97,6 +97,7 @@ mpd_headers = \
src/event_pipe.h \
src/mixer_plugin.h \
src/mixer_type.h \
+ src/mixer/software_mixer_plugin.h \
src/daemon.h \
src/normalize.h \
src/compress.h \
@@ -522,7 +523,8 @@ MIXER_API_SRC = \
src/mixer_all.c \
src/mixer_api.c
-MIXER_SRC =
+MIXER_SRC = \
+ src/mixer/software_mixer_plugin.c
if HAVE_ALSA
OUTPUT_SRC += src/output/alsa_plugin.c
@@ -741,6 +743,8 @@ test_run_output_SOURCES = test/run_output.c \
$(MIXER_SRC) \
src/filter_plugin.c src/filter/chain_filter_plugin.c \
src/filter/convert_filter_plugin.c \
+ src/filter/volume_filter_plugin.c \
+ src/pcm_volume.c \
$(OUTPUT_SRC)
test_read_mixer_CPPFLAGS = $(AM_CPPFLAGS) \
@@ -751,6 +755,8 @@ test_read_mixer_LDADD = $(MPD_LIBS) \
test_read_mixer_SOURCES = test/read_mixer.c \
src/conf.c src/buffer2array.c src/utils.c src/log.c \
src/mixer_control.c src/mixer_api.c \
+ src/filter_plugin.c \
+ src/filter/volume_filter_plugin.c \
$(MIXER_SRC)
endif