aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMax Kellermann <max@duempel.org>2011-08-28 21:52:16 +0200
committerMax Kellermann <max@duempel.org>2011-09-20 21:27:17 +0200
commit533a6b0240c10755b9c1e47ab20611f289dac412 (patch)
tree2ccd8e590cefe7feb0f00c643b6541ff8cb59aa8 /Makefile.am
parent0c0400b6fc10219ca545a25643ceabe576d5181b (diff)
downloadmpd-533a6b0240c10755b9c1e47ab20611f289dac412.tar.gz
mpd-533a6b0240c10755b9c1e47ab20611f289dac412.tar.xz
mpd-533a6b0240c10755b9c1e47ab20611f289dac412.zip
tcp_connect: generic library for establishing TCP connections
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 900f0b421..87eaf5af0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -299,6 +299,7 @@ src_mpd_SOURCES = \
src/client_message.c \
src/client_subscribe.h \
src/client_subscribe.c \
+ src/tcp_connect.c src/tcp_connect.h \
src/tcp_socket.c src/tcp_socket.h \
src/udp_server.c src/udp_server.h \
src/server_socket.c \
@@ -904,6 +905,7 @@ noinst_PROGRAMS = \
$(C_TESTS) \
test/read_conf \
test/run_resolver \
+ test/run_tcp_connect \
test/run_input \
test/dump_playlist \
test/run_decoder \
@@ -932,6 +934,15 @@ test_run_resolver_LDADD = $(MPD_LIBS) \
test_run_resolver_SOURCES = test/run_resolver.c \
src/resolver.c
+test_run_tcp_connect_CPPFLAGS = $(AM_CPPFLAGS)
+test_run_tcp_connect_LDADD = $(MPD_LIBS) \
+ $(GLIB_LIBS)
+test_run_tcp_connect_SOURCES = test/run_tcp_connect.c \
+ src/io_thread.c src/io_thread.h \
+ src/fd_util.c \
+ src/resolver.c \
+ src/tcp_connect.c
+
test_run_input_CPPFLAGS = $(AM_CPPFLAGS) \
$(ARCHIVE_CFLAGS) \
$(INPUT_CFLAGS)